Tacx Vortex training with Erg mode


(Fernando Jimenez 5656) #1

Hello Zwifters

Very recently I purchased a Tacx Vortex Smart to use with Zwift. I have set it up and done a couple of rides, and when just riding along it seems to work fine. Resistance changes on the climbs. So all good there

Today I tried one of the workouts, and made sure that Erg mode was selected. However as far as I could tell, Erg mode wasn’t actually working. At one point I was in the workout and told to hold 230W. I was complying dutifully, but then I decided to test it out and start pushing the same gear at a higher cadence, in essence producing more power. I would have expected the resistance to decrease to keep me at or close to 230W, but this never happened.

Likewise when I slowed down. Power would go down, and resistance was never adjusted.

Is Erg mode with the Vortex supposed to work? I haven’t yet tested it with the Tacx app to rule out an issue on the trainer itself (will do tomorrow)

 

Thanks for any help


(Fernando Jimenez 5656) #2

Quick update. I tried with the Tacx iPad app and erg mode is definitely working there, so either there’s an issue between Zwift and the Vortex Smart or there’s something wrong with my setup

 

 


(Rod Olliver) #3

Zwift + Vortex Smart does work in Erg mode…  maybe check that when you pair it, you choose a Smart trainer?   Also have you updated the firmware?  https://support.zwift.com/hc/en-us/articles/205107765-Updating-your-Tacx-Smart-firmware-ANT-FE-C-to-enable-Zwift-resistance-control


(Fernando Jimenez 5656) #4

Firmware is latest (that’s the very first thing I did when I took it out of the box) and I am indeed choosing “Smart Trainer” for use in Zwift. Resistance control works fine when just riding around.

I just remembered that when I switched to training mode in Zwift I also chose to read power from my power meter instead of from the Vortex, as I noticed the Vortex power is reading a bit high. I will try using power from the Vortex and check if Erg mode is working that way.


(Fernando Jimenez 5656) #5

Latest update. Indeed if I use the Vortex as the power source instead of my Power2Max, Erg mode seems to work.

Unfortunately the power from the Vortex isn’t particularly accurate. During a rest interval Zwift was showing 140W from the Vortex, while my Garmin was showing 130W from the P2M. At the other end of the scale, while doing a 270W effort in Zwift, the P2M was reporting only 240W. 

Unless Zwift implements controlling the Vortex resistance using an external (aka more accurate) power meter as the power source, I cannot really use it as a reliable training tool :frowning:   

 


(Jamie Kirk) #6

Hi - resistance on my Vortex became a lot more responsive when I paired ZWIFT with a separate cadence sensor. I also saw that my speed relative to power changed dramatically; maybe an improvement in the ERG power accuracy.

The Vortex cadence measurement was way off (much too high) and I guess that must have affected its calculations. 


(Fernando Jimenez 5656) #7

Hi Jamie

I’m not sure there should be a connection. The FE-C protocol (the signal sent from Zwift to the trainer) only needs a target wattage figure. The cadence never enters the equation.

The trainer itself will need to change the resistance applied based on the RPM of the roller itself and the target power, not the cadence of your legs. I certainly didn’t notice any difference between using the cadence from my P2M or the one from the Vortex.

Of course, if I am wrong please someone with knowledge in the matter enlighten me!

FE-C Protocol docs: https://www.thisisant.com/resources/fitness-equipment-device/  (may require login)


(Fernando Jimenez 5656) #8

Further update

I have been playing around with the Vortex and Zwift. Unfortunately no matter how often or when or how I calibrate the Vortex power, it’s still all over the place.

The Vortex reads low power at start, and increases once warmed up (10 minutes or so). However it’s not accurate once warm either. Sometimes it will read high, and sometimes it reads low (from one day to the next, without recalibrating. 

I am excited that Zwift have now enabled custom workouts, as I was looking forward to this in combination with the trainer’s erg mode. However, with this unreliable power readings, it’s next to useless.

Last weekend I was playing with PerfPro, as that app has the ability to control the resistance based on readings from a power meter instead of the Vortex itself. And I have to say, they nailed the functionality, works great. I used it in combination with Zwift (with two Ant+ dongles), and no trouble there.

To Zwift, please consider adding such a feature, as I suspect most smart trainers report rather inacurate power. Perhaps not the super expensive Kickrs or Neos of this world, but the more affordable ones for sure.

Until then I’ll keep playing with PerfPro

 

Cheers


(Paul Trenoweth) #9

I’m having the same issue with my Tacx Genius Smart, in ERG mode Zwift just does not adjust resistance well enough to meet the required wattage during a workout. Using the Tacx app it works spot on and within a few Watts. In Zwift its lucky if its within 80 watts. Tacx ant+ dongle is right next to the trainer.

One thing to mention I now dont see the option to select a FE-C trainer, now I only have the option to select ANT+ Trainer 2511, whereas before there was an option for FE-C trainer.

Is a shame as the workout mode is all but unusable, considering stopping the premium payments. Shame.


(Stepan Bouda) #10

Same setup and same problem here.

I wish Zwift could use my power2max powermeter as a power source and still control Vortex Smart resistance during power targeted workours.

The power readings from power2max and vortex are up to 15% different


(Mr. Alpaca The Avatar) #11

Does this work now?


(Paul Trenoweth) #12

I never got it to work, I gave up trying in the end. Pretty disappointing really


(Mr. Alpaca The Avatar) #13

It might in some way because Zwift Insider recommends it. They also have a manual:

https://zwiftinsider.com/vortex/


(Mr. Alpaca The Avatar) #14

Maybe ask Tacx and or Zwift to help you with a ticket?


(Paul Trenoweth) #15

Been down that road with both Zwitf and Tacx - although they were helpful we couldn’t solve the issue so I gave up on ERG mode for workouts. Normal riding resistance is controlled fine.


(Mr. Alpaca The Avatar) #16

So should I take it that a Kickr SNAP is worth the price?


(Max Brenes ODZ (C)) #17

I started having a similar problem when I purchased my P1 pedals.  When in ERG mode, the resistance on the vortex is way to low and in order to reach certain watts I’m on my big ring/small ring (52/11) and have a cadence of over 100+ rpm to reach those numbers, but the vortex sounds like it is going to explode !!! I used the mobile app to turn off erg mode and it switches to the option to increase/decrease resistance on the trainer, I bump it up just a bit and the resistance on the trainer kicks in and I’m able to reach the prescribed watts at a more comfortable cadence 85 - 95 rpm. Is that the current solution?  It seems when you have a separate device to read your power is when it occurs. Before the P1’s I did not have any issues.