TACX Vortex Smart - device no longer appearing in Power Source post Zwift update

I have been using Zwift for the last week with no issues but today i noticed that there has been an update and i’m guessing its linked to the issue i’m experiencing with my smart trainer. The smart trainer is no longer appearing in the ‘Power Source’ box in the “Paired Devices” menu but it is being picked up the ‘Speed Sensor & Classic Trainer’, ‘Cadence’ and the “Controllable Trainer” boxes. I am using an iPhone 6 with the zwift mobile link app.

You can still use zwift with the smart trainer in the other boxes but there is no resistance so is pointless.

I have been in touch with support and they have responded with the below.

A quick update - it looks like there are a few other people with the Vortex experiencing this issue so I’m getting QA on the case.

I have the same issue with my Flow Smart, last day of my eval so I hope they fix it quickly

i doubt it will be fixed today but lets hope.

This was the last update. I don’t have an Ant+ dongle :frowning:

One more quick update - this looks to be a known issue with Tacx/Elite trainers and Bluetooth connection using the Zwift Mobile Link. We’re zero-ing in on the issue and it looks like it happens intermittently and at seemingly random times.

Do you happen to have an ANT+ dongle handy? Because that does not have any issues at the moment. We hope to have a fix very soon.

Eric C.

I guessed it might be BT specific so ordered a dongle but won’t be here until tomorrow

Jeff please can you send us a link to the Ant+ dongle as i’ve been thinking about getting one.

I went for this one, comments show it works with Zwift, its under a tenner and on prime. It’s a bit bigger than the Garmin one but if you’re putting it on an extension cable to keep it near the turbo that doesn’t really matter.

https://www.amazon.co.uk/dp/B00T7C2DWA/ref=sr_ph_1?ie=UTF8&qid=1475240518&sr=sr-1&keywords=ant%2B

Same issue with my Tacx Vortex Smart. Through MobileLink it will recognize it as a ‘controllable trainer’ and as a cadence sensor. But no Powersource so cannot actually move in Zwift. Also, when I tried to connect it through BT on my Macbook Air it crashed Zwift. I submitted a ticket additionally.

back working again now thanks to the Ant+ dongle that Jeff recommended :slight_smile:

Me too, and all signed up, so please don’t break anything else guys :slight_smile:

Same problems with Tacx Neo,  I opened a ticket.

Really mad that I spent over an hour in my pain cave doing technical support instead of working out…

I am very angry about that issue.

I bought a Tacx neo smart a week ago. at that time i can play the zwift with tacx through the power source

Today I can’t find my Tacx neo In ‘power source’ but anyway there is a tacx neo in classic… what is that ???

even I ask on the Facebook every guys laughing at me ! -_-^

 

I am having the same issue. It had worked fine until today, and now, my tacx neo does not show up in “Power Source” anymore. Useless.

I thinking about cancelling my account

Having same issue with a Tacx Vortex Smart over BLE. I researched this in advance before I bought the Tacx a few weeks ago, because my Polar HRM uses BLE as well.

Mine stopped showing up as a power source Friday, and I received this email from Tyler in support:

“…you have run into a bug that we discovered in the last few days. The Tacx Vortex has stopped registering as a power source while using BLE, which will throw all your data our of order. Luckily, we believe we found the problem, and are planning to have a fix out ASAP. I’m going to keep your ticket on hold for right now, until I can give you more information, or a possible work around.”

Have heard nothing since.

I tried using as a traditional Tacx trainer, but I was going 4 kph at 90 RPM cadence, which was WAY too frustrating. So now I can’t use Zwift at all.

Have had the same happen with my Satori Smart. Tacx utility etc. all works, but Zwift only recognises speed and cadence, no power.

Same problem here too – it pairs as controller & cadence, but not power. Just purchased a Vortex today and have been trying for the last couple of hours to connect, then googled this thread.

Hopefully this will be fixed soon. In the meantime I’ve ordered an ANT+ dongle, so hopefully that will mean I can get zwifting soon.

Anyone know if this is fixed in the 10/4 update? It’s not an issue for me since I got an ANT+ key but I’m interested to know as it should be an indicator of how well managed the Zwift platform is and how quickly we’re going to see bugs squashed in the future. It isn’t mentioned in the release announcement

https://support.zwift.com/hc/en-us/articles/213493066-What-s-new-on-Zwift-10-4-1-0-14502-

 

I updated the Zwift app this morning with high hopes, but had the same problem again.
Waiting to see if an ANT+ dongle will fix for me.

Jeff,

I updated mine this morning and i also updated the ios app (Mobile Link) but it’s still the same and will only work using Ant+.

Ouch, thats not good. It really should be a simple fix and a high priority for them as it’s fundamentally broken the basic functionality of the platform.To release a patch without a fix for that is at best surprising and at worst incompetent.

That’s very disappointing. The last I heard from customer support is a 50/50 chance of having an update out late this week, or early next week. Going to go ahead and order a ANT+ Dongle.