Tacx Satori setup on Zwift

(Alan Earls) #1

I’m trying to setup a Tacx Satori on Zwift, I’ve read through different threads and tried a number of different ways but not having much luck. I have a windows laptop, android phone (both bluetooth) enabled and also a Tacx ANT+ dongle. 

Appreciate any advice you can give me on the correct setup here or if I a missing any other kit? Thank you

0 Likes

(Paul) #2

If you are using Bluetooth make sure the trainer is not connected to any device or app since Bluetooth can only make one connection at a time. To connect the trainer using Bluetooth you would need to use the Zwift Mobile Link on your phone to bridge the signal to the Zwift app running on your PC. Make sure within the ZML that in settings>Sensors you have BLE turned on.

You cannot connect the trainer to Zwift on a PC by using Bluetooth directly.

ANT+ is much easier, make sure that the dongle is installed on your PC and make sure you turn on the trainer (button is on the left-side of the trainer and the light will flash once on) and open up the Zwift app and on the pairing screen click search under power source.

Make sure the trainer is broadcast good and is up to date using the Tacx app, but when you want to connect the trainer to Zwift you need to make sure the Tacx app is close since Bluetooth can only connect to one device/app at a time. Also make sure you do a calibration test once in a while to ensure it is working correctly.

BTW, I have a Satori and it works well for Zwift. 

0 Likes

(Alan Earls) #3

Thanks Paul. I’ll give all of that a go tomorrow and let you know :slight_smile:

What sort of ANT+ dongle do you have on your PC? I’m thinking that might be the way to go as I’ve already spent a long time messing around with the Bluetooth connections. 

Would this do the job? https://www.evanscycles.com/en-ie/garmin-usb-ant-stick-EV165973

 

0 Likes

(Paul) #4

I have this one: https://www.amazon.com/GXG-1987-Compatible-Forerunner-011-02209-00-Fitness/dp/B071DX5RFP/ref=sr_1_2_sspa?s=electronics&ie=UTF8&qid=1511887637&sr=1-2-spons&keywords=Anself+USB+ANT%2B+Stick+Compatible&psc=1

And this to get it close to the trainer: https://www.amazon.com/AmazonBasics-Extension-Cable-Male-Female/dp/B00NH11PEY/ref=sr_1_4?s=electronics&ie=UTF8&qid=1511887574&sr=1-4&keywords=AmazonBasics+USB+2.0

But the Garmin ANT+ dongle will work, but make sure you get a USB extension to get it as close to the trainer as possible.

 

0 Likes

(Alan Earls) #5

Getting a bit further today with the suggestion above but still having some issues :( 

Just testing using the bluetooth connection only. I have the Satori connected to an android phone where ZML is running. When I open the game on the laptop it shows at the paring screen it shows bluetooth connected with radio waves but when I search under power source I get nothing. 

Trainer is on, led is flashing and its not connected to anything else. Any suggestions? Has anyone seen this before?

0 Likes

(Paul) #6

Disconnect the trainer from your phone and make sure within the ZML Settings>Sensors (I have an iPhone so hoping it’s similar) that BLE is turned on. The trainers needs ONLY connect to the ZML, not your phone.

 

0 Likes

(Alan Earls) #7

Sorry that’s what I mean’t, the phone and trainer are not paired - bluetooth is enabled on the phone but has no connections, same with trainer it’s on and has no connections with Tacx. No sensor setting on android ZML but I have read that the BLE connection is automatic. 

Laptop bluetooth is turned off but on the same network as the phone. When I open Zwift on the laptop it logs in ok (and I can see the game screen then on the ZML) but no options to pair on the laptop (even though bluetooth connection looks ok, seems like its searching for the trainer, just not picking it up) I even deleted Tacx from the phone just in case and have restarted everything about 12 millions times :) 

 

0 Likes

(Paul) #8

Have you click the search button under power source on the Zwift pairing screen.

0 Likes

(Alan Earls) #9

I have indeed Paul…many times no joy:(

0 Likes

(Paul) #10

Also, I would put the phone in Airplane Mode and just turn on the Wifi and Bluetooth to see if it connects.

0 Likes

(Paul) #11

Now I remember why I switch to ANT+. 

0 Likes

(Alan Earls) #12

Just tried airplane mode there with WIFI and BT enabled…still no luck. Yep it’s looking like I’ll be switching to ANT+ also . 

Thanks for all the help, will let you know if I ever get it sorted :slight_smile:

0 Likes

(Paul) #13

It’s a small price to get a consistent reliable connection.

 

0 Likes

(Alan Earls) #14

Just to say that the ANT+ dongle arrived yesterday, nice and easy to setup and I was on to Zwift within minutes. Shame to spend 3 days playing around with Bluetooth connection!! Thanks for all the help :slight_smile:

0 Likes

(Paul) #15

Yep, ANT+ is very easy and Bluetooth sucks for now.

0 Likes