Tacx Genius Smart; no resistance on hills and cannot see the “Trainer Difficulty” setting


(Jelle Wijnja) #1

I’ve just started with Zwift. Did three rides and absolutely loved it. However I do not feel any extra resistance on hills and also cannot see the ‘Trainer Difficulty’ slider. Hope some-one can help me to get a more realistic experience.

Some additional information

  • I am using an iPad connecting to the Tacx Genius Smart with Bluetooth;
  • All other apps on the iPad are closed before opening Zwift.
  • No other device is connecting to the Tacx Genius Smart (Bleutooth of the laptop and phone is switched off)
  • Zwift is paired with “Power Source”, “Cadance” and “Controllable trainer”
  • I am riding in the “Free Ride” mode (no work-out)
  • With the Tacx software automatic adjustment of the resistance does work with hills.

 


(Jason K) #2

Hey Jelle, it sounds like you’re doing everything correctly. Since we don’t have a Genius Smart in the office to test with at the moment, I’m turning this into an email support ticket. Keep an eye on your inbox for more information, and we’ll go from there.

Thanks!


(Luke O'Brien) #3

I am having the same problem with zwift and a tacx smart trainer. It worked until recently. I did a calibration check and all is within range. The lack of resistance is making rides pretty pointless


(dean giesbrecht) #4

I am having the same problem.  Please help.


(Mark KL NL) #5

Same. Is there an answer yet? Why is this so complicated?  


(dean giesbrecht) #6

They helped solve my problem by, Updating the firmware through the tacx utilities app and I did not have the menu settings done correctly.  see the link for the proper settings - the difficulty has to be in the middle, and swift has to find the trainer and link in three spots:  power source, cadence, and under controllable trainer for it to work.  Hope that solves your issue.

 


(Michael O'Leary) #7

I too have the Genius and seeing weird behaviors.  I use the Garmin cadence sensor on my bike vs. letting the Genius calculate it.  I was doing a training ride where I was to sprint and make 450 watts.  I could only make like 390 watts in the smallest gear on the cassette and 115 rpms.  So the resistance is not going high enough on the trainer.  Any suggestions?


(Martin Hoffman) #8

Hi

I have the same problem. TACX Genius Smart T2080. I have absolutely no resistance at all and with the highest gear I look like Roadrunner. I have the latest firmware from TACX Utility installed.

Very keen on finding a solution.


(Gerrie Delport) #9

I assume the TacX does not have ERG mode, so you have to change the resistance with the resistance buttons on the app. this is in workout mode.

Is your resistance set to max? See image below, that orange slider can go all the way to the top. Use the resistance arrows to change it up and down.

 

 


(Martin Hoffman) #10

It is ERG compatible but I’m training in free ride mode and I can’t find the resistance arrows. Maybe I don’t have the menu set up correctly as the user above? 


(Gerrie Delport) #11

This is for workout mode.

See my pictures below. Or you can use the + and - on your Key board (KB)

 

Figure 1: Mobile link app

Figure 2: Zwift game (press up arrow on PC KB to get this menu)


(Gerrie Delport) #12

If you don’t have resistance in free ride you need to pair it as power source and controllable trainer.

Set your trainer difficulty setting to max and test again, 

 


(Martin Hoffman) #13

Thats it! Thank you, I’d completely missed that one.

Cheers!

Martin