Tacx Flux S can’t pair alongside PM, iOS

Hi,
When using Zwift on my iPad Air and iPhone 8, my Tacx Flux S will no longer act as the controllable device whilst my 4iiii left side Crank PM is set as power source (both connected via BT). This did work fine up until ~ 1 month ago. If I setup the Flux initially as Controllable and then also as power source it seems to work, however if I select the 4iiii as power source first, then the Tacx isn’t even selectable. Whilst setting up Flux first as controllable first and 4iiii as power source after appears to be doable, the Flux provides no additional resistance in-game and is effectively dumb as long as the 4iiii is active.

I have checked the Flux reads properly into the Tacx app, ensured Zwift is only running app, reset devices multiple times and behaviour is repeatable across both phone and tablet. All devices are on latest FW. It wouldn’t be a massive issue, but there is a discrepancy in power reading between both, and I use the PM as reference for training, so it would be good to get this sorted! Thanks.

What version of the Zwift app are you using?

1.15.1 (75994) on both.

Hmm, I believe this problem was meant to have been resolved in the patch update but you already have it. Try this: Can't pair both Controllable and Power signals separately [1.15.0] [July 2021] [SOLVED] - #164

There’s also a potential solution a bit further down.

Thanks. Tried all of the suggested fixes, and as a few have highlighted in the other thread, it is still broken.