Suddenly plagued by Bluetooth dropouts


(Nathan) #1

I’ve been happily Zwift since October last year. I don’t think I’ve seen a single drop out until this week. On Monday I had to abandon my workout because the connection to my KICR Core kept dropping out. Rode again last night and had one drop out early on that meant I dropped from the group and was too far behind to catch up and a 2nd drop out late in the workout.

I’m struggling to understand what’s changed. I ride with Bluetooth headphones which have been absolutely fine to date. I turned them off after my first drop out last night to see if that was the problem, but it still happened later in the ride. My wife uses a treadmill in the same room with a Bluetooth HR monitor, but this has worked fine for months without a single issue.

Is there anyway I can identify what is causing the Bluetooth interference? I spent most of my time in Zwift in group rides or races. When a single drop out causes you to drop out of the group and makes the entire session pointless, I can’t see myself continuing with zwift if I can’t get this issue resolved. Which would be a massive shame because I’ve been loving it way more than I thought I would!


(Gerrie Delport TeamODZ) #2

Did you try to put your log file in Zwiftalizer.com? That may help you find the issue.


(Christian) #3

I had the same on Monday night. Been using fine for the last year and dropped three times until I gave up. Seems to be working fine again now though.

I use the companion app on an iPhone to link through a computer.

For me it dropped out each time I tried to up the work out intensity in ERG mode.


(Nathan) #4

This is a great tool! Thx for the link


(Simon) #5

Have you changed your wifi setup, bought a new microwave oven or other electrical device. A simple change of wifi channel can sometimes help.


(Jason) #6

I’m having the same issue, only with my ATV 4K. Been working fine for a month (since I got it). Then one day I had a few drops, and now it won’t even connect. I always get “No Signal” on my Kickr connection. To my knowledge, that means the ATV sees the trainer but can’t pair with it. I’ve done factory resets, turned off as many bluetooth devices as possible, to no avail. I may return the 4K to the Apple Store and see what they can diagnose, because my iPhone and older ATV don’t have this problem.