Struggling to connect Garmin 810 to Zwift


(Andrew Hillier) #1

It was with a great deal of excitement that I signed up for Zwift. All the website told me was that i needed a trainer, a bike computer with cadence and a ANT+ dongle. It didn’t matter that i don’t have a power meter as Zwift has an algorithim to take care of that.  I already had the trainer - a Kurt Kinectic Road Machine, i have the bike computer - a Garmin 810 with cadence and heart. All i needed to get, according to the Zwift site, was the ANT+ dongle. So off I went and purchased one.

When the package arrived I eagerly got started setting it up so i could join the race. Only problem is it turns out that the Garmin 810 doesn’t talk to the ANT+ dongle… so now it seems like I am stuck, one small link missing.

Does anyone know how I get the Garmin 810 talking to the computer in real time? Is there another way to do this?  I desperately hope so cause Zwift looks amazing and I really want to be able to join in!!!

One other thing. Zwift, an upgrade for your website could be to detail which bike computers do and don’t talk to your program.

Any help would be truly appreciated!

 


(Andrew Williams) #2

The 810 is not a speed/cadence sensor.  It is an ANT+ and GPS receiver/computer.  You need an ANT+ speed/cadence sensor.  The GSC-10 or something like it.


(Andrew Hillier) #3

Hey there Andrew. Thanks for the feedback. Clearly I am not at all techie. I had always assumed the 810 is the device that acts as the hub - receiving info and sharing it (for example with the Dongle).

Your comment has completely changed that point of view. So the 810 is just another receiver of the data, in the same way the ANT+ dongle would be. Thanks for the perspective change / correction - suddenly Zwift seems close again.

So I do have the GSC-10. That is where my 810 gets is receiving its info from. (well that plus my heart monitor). But, this raises an interesting follow on question. Since I do have the appropriate hardware, why is Zwift not detecting the GSC-10. Everytime I log into Zwift, it just tells me nothing is there. I had assumed it was cause of the 810 not talking to the ANT+ dongle. But as this is not the case, do you have any thoughts on what my next problem is?

 


(Andrew Williams) #4

If you go to the pair screen and click on “Search” for Speed, does nothing show up?  If so, it could be that the distance to the computer is too far, or the battery in the GSC-10 is weak, or maybe the ANT+ dongle isn’t working right or maybe it got grabbed first by some other app like Garmin Connect. 


(Rob Fleischmann ZHCC) #5

Andrew,

As Andrew Williams suggested, the most probable cause is that the Ant+ Dongle is too far from the GSC-10.  You can purchase an Ant+/USB extension to run from the computer and place the dongle in close proximity to the GSC-10 (like on the floor right below it.  Also, you might try rotating your crank by hand after you push the search button to make sure the GSC-10 is transmitting data.  Is it picking up your HR monitor?


(Andrew Hillier) #6

Thanks Andrew and Robert! I really appreciate your insights. I do have the bicycle right next to the computer with the Dongle in it (at most 1.5meters). But I run through each of your suggestions to try trouble shoot and get this thing working.

Great question about the HR Monitor. It was not picking that up even though I had it on while I was using the program and my bike was picking it up.

Hopefully it isn’t a problem with the dongle. But some trouble shooting should determine that

Thanks again gentlemen! i really appreciate your feedback!

 


(Rob Fleischmann ZHCC) #7

Andrew - Just for comparison, I have the dongle about 15" from the speed sensor.  But the fact that it’s not picking up your HR monitor makes me think something else is going on.  Could be the dongle, I did have some trouble fitting it into the USB port.  Might be worth uploading the software again.  Otherwise, I would suggest submitting a help ticket to the Zwift Boys.


(Andrew Hillier) #8

Yeah, sadly I think that is the way it is going. I will try each of the steps you and Andrew have suggested above to ensure that they are not the cause. After that we will have to look at whether or not the Dongle is working. I did get it from a reputable dealer, so hopefully there is no technical issue there.

Good thing i am hope alone tonight or it would be a boring evening for my wife!

 


(Rob Fleischmann ZHCC) #9

Andrew,

Is it safe to assume that you were able to create and save your rider profile before attempting your ride?


(Andrew Hillier) #10

yes, that is correct

 


(Eric C. (Zwift HQ)) #11

Andrew,

Please be sure it is a USB 2.0 dongle as well. If it is, then a USB extension cable will quickly solve the problem.


(Andrew Hillier) #12

Evening all. I got it to work. It was all about thinking i had to try link my 810. I was going down the wrong road from the first turn…

Anyhoo, all is good now! Thank you all so much for your help! This is an amazing community. Everyone was so quick to offer support!

Hopefully i will come across some of you on the ‘road’.

Thanks again!!!

 


(Russell Young) #13

Hi Andrew, I’m getting the same issue - ie. Garmin USB Ant stick but searching wont find HRM, Cadence or Speed sensors - what did you do to resolve the problem?

Thanks

Russell


(Russell Young) #14

ps. Its definitely a USB2 ant stick - all devices get paired when I turn on the Garmin, just that the pc/zwift cant find them - not running the ant+ agent or garmin express etc either.


(Reuben Booker) #15

I have a Garmin HRM & Cadence monitor. They connect instantly to my Forerunner 405. But when I disable the watch, the HRM and the cadence monitor fail to connect to the ANT+ dongle. I’m sitting on the floor next to the bike pedalling and the HRM touching the dongle. Still no connection. 


(Russell Young) #16

My ant+ stick is quite old - must be > 4 years - but it does say USB2, and Zwift does find it (zwift gives a message if it cant find one, I plug it in, the message goes away)…  Is yours an older style one Reuben?


(Reuben Booker) #17

My stick is very old as well. I got it back in 2009 I believe. However when it’s not plugged in Zwift alerts me there is no dongle plugged into the laptop. Plug it in and the message goes away. 


(Andrew Hillier) #18

Hey there Russell, sorry for the slow reply. I have been away from my computer and email for a few days. Are you still experiencing the problem?

The advice I got from the guys above was invaluable in me connecting. Looking back now, i think the biggest problem i had was that my Garmin Connect program was on while i was trying to connect. I would open up Zwift and it would show me the screen where you connect to the Cadence and HRM devices, but I would get a note above that screen saying I did not have a ANT+ dongle - even when I had the dongle in place.

After reading the advice from Robert and Andrew, I did the following:

1. I made sure that the Dongle was in (the computer actually made a boing noise confirming that it was)
2. I made sure I did not have Garmin Connect on.
3. I spun the wheel of my bike to activate the cadence sensor
4. I then switched on the Zwift application.
5. It automatically took me to the connection page (having followed this order i no longer had the message saying there was no dongle)
6. I clicked on the cadence sensor image to start the computer searching for the cadence device.
7. Once i had found and connected to the cadence device, I clicked on the HRM image to start the computer searching for the HRM device.
6&7 - in both cases the computer found the devices instantly and i just clicked on the device in the list the program provided (only one item on the list). Since then, i have not had to search again they are automatically paired.
8. i climbed on the bike and started riding.

Overall my set up is as follows.

  • Computer with Zwift application on it and ANT+ dongle attached. Garmin Connect off.
  • Garmin speed and Cadence sensor
  • Garmin HRM
  • Garmin 800 bike computer - i have this on the whole time and it does not impact the running of Zwift.

Hopefully this is helpful. please let me know if not. Sorry if this is not the correct technical words.

Andrew

 


(Russell Young) #19

hi Andrew, thanks for response - I think your problem was different to ours - in our scenario the USB stick is found and recognised by Zwift, but the devices aren’t (HRM, Speed/cadence)

Ive given up, but guess it’s probably just down to the fact our USB sticks are a few years old.


(Russell Young) #20

Issue is fixed in the current release - just tried again, no changes my side but it just works - I see some other threads complaining at around the same time as I saw the problem originally, sounds like it was caused by a bug in the software update at that time