Street surface

Hello.

I have TACX Neo 2T and is running Swift.

The impact of the street surface disappeared. If I test on TACX witout Swift it is ok. But with Swift it is as plain asfalt independent of the street surface.

The Tacx is running the latest update available.

Any propsal?

Best from Finn Arve

Is the ‘road feel’ toggle turned on in the settings?

Hello and thanks for the proposal.
There is a “Resistance” Icon on the Zwift screen. Is this the “road feel”?
If not, In which settings and where do I find it?
Best from Finn Arve…

I think this video will explain it. But you will find the road feel setting in the settings menu. Once you are in-game, select the Menu option in the lower left corner, then select the Settings icon.

Can you not access that setting from the home screen settings menu too? I don’t know, I don’t have a Tacx.

Yes! That should be possible, too. I completely forgot about that.