Strange issue: scrolling in Zwift through macOS screen sharing is broken

I often start the mac system I use for Zwift and use Apple’s macOS ‘Screen Sharing’ on another mac to select and/or edit workouts prior to riding. Every time since I started doing that, scrolling has worked perfectly and yet yesterday (first time post updates), I was trying to select a workout, and scrolling was not working, and the scroll bar minimizes.

Now before people suggest it’s macOS doing this, scrolling did work in Firefox, and every other app I tested while sharing the screen. Scrolling, incredibly, does not work (for me at least) in Zwift while screen sharing. Both systems were recently updated with the RSR (Rapid Security Response) update from Apple, and of course Zwift was also updated yesterday.

I was kind of stunned/shocked that scrolling wasn’t working. Weird…

Is anyone else having this happen? I’ll try again today and report back…

You can always try uninstalling the RSR to see if that makes a difference.

Open System Settings > General > About, and look down for the macOS version. At the right of that line is an ⓘ button: click on it to access the the ability to uninstall the RSR .

Pulled it off the ‘Zwift system’, and still broken. Pulled it off the main system and…

It will not scroll if the cursor is on the main part of the window where the names are, but WILL scroll if the cursor is on the alley/scroll bar. Strange…

Of course, no idea if this is caused by an artifact of having the RSR installed.

The ‘Zwift Machine’ did have an artifact post RSR that was replicated post install. It came up with a patterned orange screen with only the name and password blocks, no avatar. The footer choices where there, and after a restart it looked normal, and has since until immediate post RSR uninstall where I got the same mostly blank orange login screen that once again reset after a reboot. (The main system post original RSR install couldn’t connect to the wired Apple keyboard until I unplugged it and then macOS found it immediately)

So, the RSR ‘has issues’, and it appears that possibly, post uninstall, some of them may linger. The next obvious thing would be to reinstall both systems OS, but I’m not going to do that. But this is an interesting development.

Is it the RSR? Probably. Is it the Zwift update? Potentially. Is it possible they don’t play well together? Who knows. It’s all speculation, but weird to be sure… I do have an M1 Mini that I could swap in and see if scrolling works, but that isn’t exactly comparing ‘Apples to Apples’. I just have to find that sucker. When I find it I’ll try again, and post results.

FWIW, the RSR is delivered as a removable Cryptex that “most likely” did not directly cause this issue. The OS itself is a signed and sealed volume that will not even boot if a single element has been altered, so this i more likely an issue with the Zwift update itself.

Long story short, if you have uninstalled the RSR and still see the odd behavior, it wasn’t caused by the RSR itself.

Here’s hoping you manage to track this down!

And, well things were interesting…

The ‘Zwifters Nearby’ box was going nuts. Scrolling all of the way up, and seemingly all the way down. Didn’t matter if I clicked on anything, (trying to acknowledge things in that window made it worse as they scrolled past before I could click them) just having the cursor anywhere in the Zwift window seemed to make it skittish too, but then it just appeared to be random at times too. (I have a screen cap video)

Then the buttons at the end of the ride were flickering like crazy too. During the ride I did go to Accessibility to make sure that nothing was set that I wasn’t aware of, and it seemed okay.

So if this was the RSR, that thing is Not Ready For Prime time. If it’s an interaction with Zwift and the RSR, then I’d put out the word to wait on the RSR. If it’s the Zwift update, then it needs more time in the oven.

Disclaimer: my 9-to-5 has me managing 2000+ macOS devices at the OS level for the last 15+ years…

It’s not the RSR - I can assure you.

One possibility is that it’s a bit of Apple’s somewhat feeble implementation of VNC for screen sharing, perhaps also combined with the idea that using Zwift in this specific way was not something Zwift HQ considered in their final move to Metal vs. OpenGL.

I’m sort of surprised that you’ve been able to interact with Zwift effectively via screen sharing as long as you have. Also, bear in mind that Apple is also increasingly concerned about device security and does actually implement some contextual roadblocks at the OS level when it comes to screen sharing and remote interaction in general. It’s possible that the UI programming done by Zwift might be conflicting with some of these restrictions on remote interaction as of the 1.39.0 update.

At this point, opening a support ticket about this directly with Zwift might be your best option if you haven’t already gone that route. I’m happy to offer what I know here about macOS, but I can’t speak directly to any changes Zwift may have done with this last update.

Good luck figuring this one out!

So that has to be like herding cats on occasion. I assumed you were either someone with Zwift, or knowledgeable in the dark arts.

I will put the RSR on again and see what happens. The UI freakouts on the Zwift system were really pronounced and a major distraction. Seeing that window thrash up and down at random was distracting.

Even when screen sharing did work, it was spastic at times. Scrolling was a little sketchy, but worked. Yeah, it could be better, but it also could be worse.

I owned a computer company for 40 some years and it was always interesting, and loaded with stress. Finally got off that horse. I remember when making a profit doing it was easier. But anyway, thanks for your help. Ride on!!

Do you have any advice in dealing with a spam mail attack? I think someone signed me up for a massive attack, getting hundreds of messages an hour. macOS Mail rules don’t work, and Apple keeps saying to use iCloud rules, which are cumbersome and pretty much useless. I did something wrong somewhere and just can’t get control of it.

I am looking for a programmatic way to trigger Mail rules because if they run, they kill it, but they don’t appear to run anymore.

Believe me, there has been a great deal less cat herding since macOS Big Sur when Apple moved toward the signed and sealed volume for macOS - now when things break, it’s much more likely related to either settings in the user account space, or 3rd-party stuff with programming issues - under Ventura, which so far is the only version of macOS receiving the RSR updates, the OS is even more bulletproof in terms of resistance to infiltration.

The way Apple has built their RSR mechanisms is such that the OS itself is never being altered, so if you removed it and are still seeing odd stuff, something else is at the root of the issue - ultimately, any rapid security response changes will be rolled into a future dot version of macOS, anyway, and Apple built the RSR deployment with the flexibility to, in effect, remove that specific RSR Lego brick from the macOS baseplate in the interim. Reapplying the RSR is not going to be effective in helping to troubleshoot your rendering/UI strangeness.

I guarantee that Zwift HQ would be interested in your case, and I still recommend opening a support ticket with their team - you may be experiencing something common to others who may not be reporting the issue, so getting Zwift support involved here would definitely be the way forward.

As far as Mail goes, I stopped using the client on everything but my iPhone and iPad years ago in favor of using only Gmail on desktop machines - I only ever interact with my iCloud email using my phone or tablet, so I’m pretty out of the loop as far as how the macOS Mail client might have changed - generally speaking, however, Mail’s spam filtering as presented on iOS/iPadOS has been solid in my experience.

Generally speaking, flagging emails as spam when using the Mail app has been successful at “teaching” Mail’s spam heuristics effectively, so I’m uncertain as to your specific disconnect in this case.

Good luck getting this all sorted, and by all means, Ride On!

Yeah, people tell me to dump macOS Mail all the time, but I’ve used that address for a decade. It’s hard to get people to change to a new address. Too hard. Hah!


More issues…

If I go to edit a workout, and click on the ‘Power Two’ box for an example, and hit the right arrow (or left) it jumps to the next box on the screen, not to the right or left of the content in the box.