Strange crash issue today...


(Jim Hansen (Seattle)) #1

I decided to try for my 100km achievement this morning.  A friend was online and I joined in with him for the first few miles.

We were chatting (via PM)'s and for some reason, I got a “ZwiftApp.exe is not responding” popup during the ride.   This is the first time I’ve had the app crash, and coincidentally, it was also the first time I ‘joined’ another rider on login, and was exchanging private chats.   Probably coincidence, but it’s worth noting.

Anyway,  I lost about 8 miles of my 100k effort, so i figured I’d start again solo (my friend logged off when I crashed). 

About an hour into my 2nd ride, I stopped to fill my bottles and take a potty break. I was probably away from the game for about 10 min.

When I returned, the game was still paused, but I noticed the data panel was greyed out, and I had no data from any of my ANT+ sensors (KICKR, BlueSC, and TICKR).  I tried opening the pairing menu, and it would reconnect everything, but as soon as I started riding, all of the ANT+ connectivity would drop out again.  I tried some troubleshooting, including unplugging and re-plugging my USB extension cable.  No joy.

I really didn’t want to lose my progress (for a second time), so I opened a browser and checked to see if the data was on my Actvities list, and sure enough, it was there.   In the game, the current ride was still active (time showing just over an hour, distance, etc…), but the activity list made it appear that the ride had ended.  Strange…

I was unable to continue that ride.  No hope of the 100k achievement.   I tried to close the game, and it crashed again (same popup as before).  No idea what caused this.

I rebooted the machine and started another ride. Everything seemed to go well.  I rode another two hours, and got close to 100k (total across the three separate rides), but because the activities were not linked, no hope for the achievement, so, feeling a tad discouraged, I bailed at 2 hours.

Is there a diagnostic log we can check for the cause of the crashes?  

 Also, I’d like to include a suggestion that we be allowed to continue a ride after a crash like this (assuming we resume within a reasonable amount of time).  It’s really annoying to set aside this much time to try for an achievement and not get it because of a crash. 

 

Edit: I should add that I know I didn’t lose Internet connectivity, as I had some streaming video coming in on another computer.