Sterzo takes me off course

I’ve been using Sterzo elite for about a month now - windows platform with companion on android, all good until a week ago- with Sterzo enabled takes me off the course of the pacer group I joined at the start of my ride and will not allow me to correct. I’ve given up and no longer using steering, so even though I cannot turn on purpose with Sterzo- it does it on it’s own

Hi @M_Michaels

Sorry to hear that you’re having this issue. If you haven’t tried this already, it could be that it needs calibration. Check out this article that we have, particularly towards the bottom where it discusses the calibration process and try those steps to see if it improves your situation. Another thing is making sure that the batteries are still good, and may not hurt to pair it up to the Elite Upgrado app and make sure no firmware updates are needed.

If those things don’t help, reach out to our support team and we can start taking a deeper look into this issue.

The fix you recommended very slightly improved steering predictability but did absolutely nothing for the going off course problem. I tried going to the forums there is no answer there and there is nobody else that I can contact to solve this problem.

Message generated on my mobile device

Hi @M_Michaels
I don’t know whether we have the same issue, but I’ve been highlighting the same experience for some time now. The problem I realised is that during RP rides, I am totally focused on using the Sterzo to maximise draft position, without realising that it can flip to route options at intersections (that I ignore because I’m focused on my position and just assume Zwift will make me track the RP). See my posts below:

So actually, I have been “choosing” to steer away from the RP without realising, and I’ve been thinking it’s a connection, software issue etc.
Having paid more attention for the last couple of rides, I have seen the wrong route option selected (I think because I was steering for the draft position), then quickly reselected to stay with the RP.
I’m still not happy with this issue because occasionally I’ve needed to steer for the draft, but this has inadvertently forced me off the route when the left/right markers pop up, and I haven’t switched directions with the handlebars quickly enough.
I’d be interested if you try a RP ride and watch carefully how you’re steering when the route options come up.

Thanks that is a possibility, I’ll look for it. Steering is still in beta it seems, but it definitely makes the whole experience more immersive.

Message generated on my mobile device