Stages SB20 Not Controllable [December 2021]

Just adding another thread with more specific title so this gets addressed. Can’t use my SB20 after 1.20 update

Bluetooth or ant+ ? and what platform iOS or Windows ?

BooX

1 Like

or Mac OS and if so, what version.

1 Like

Still an issue, but on @Shane_Miller_GPLama YouTube vid under comments he said that the controllable showed up eventually if you wait long enough.

2 Likes

Same issue with my SB20 after the update. Connection is over Bluetooth with Zwift running on an iPad running 15.1. I tried power cycling the bike (twice even), that didn’t help. Disconnected blurry on the iPad. That didn’t help either.

Any hint at how long “long enough” is? I was waiting several minutes while in the pen tonight. I didn’t track how long but it was at least two minutes.

1 Like

My setup/fix:

  • Windows 11
  • ‘Repaired’ the Visual C++ redistributable install.
  • Rebooted.
  • Deleted knowndevices.xml
  • Started Zwift.
  • Using direct BLE or Companion App pairing the SB20 pairs as power/cadence… Controllable shows within a few seconds of searching.
  • (ANT+ FE-C was fine all along…)

YMMV. This sledgehammer fix needs performing way too often. I suspect it’ll be a more robust fix for people who always use the same hardware/trainers/etc.

6 Likes

Same, Stages SB20 and variety of ATV and iPad for the game. Will try waiting a longer time tomorrow. Zwift tech is working with me and have been responsive. I don’t get the same problem with my tacx neo 2t

I’m on latest iOS version with iPad. I waited like 10 mins earlier tonight and that didn’t do the trick

Having the same issue, unable to connect as controllable to the Stages SB20.

Same Issue here. Running on an Apple Tv with Bluetooth connection

Issue also happened for me after yesterday’s Zwift update. Stages SB20 + ATV (recently updated to latest TvOS). I have always connected by Bluetooth, to the bike, for power, cadence, and controllable. Zwift is unable to find the bike for controllable now.

Same issue for me on an iPad. Controllable will not pair. However, I raced on my temporarily dumb SB20 last night and the brake worked well for quick resistance changes. So it’s at least useable until an update fixes this. Hopefully soon (not Zoon).

For what it’s worth… I was able to correct my SB20 connectivity issues on AppleTV (not controllable) this morning by deleting the app and reinstalling. Now there is a bit of delay for the SB20 to show up as a “controllable” (maybe 1-2 seconds) but other than that I’m back in business.

what app are you saying? the Zwift app on the appletv?

yes. But I have a feeling it would also work for iOS. Basically I saw a solution somewhere for a Windows user that involved deleting some individual configuration files to do a kind of reset. Doing that for Apple mobile or TV apps is a real pain. But deleting and reinstalling achieves the same result… although it’s a much more blunt tool approach.

Works properly with Mac M1 mini running Big Sur.

A server-side change was reverted last night, which should have restored the ability to pair the Stages SB20 as Controllable again on the latest game version. If you are still seeing this issue after closing and re-opening the game today, please let us know your configuration details:

  • Which platform are you running the game on? (e.g. AppleTV, iOS, etc)
  • Which OS version is being used?
  • Which connection type are you using? (Native Bluetooth, Bluetooth via Zwift Companion, or ANT+)
3 Likes

Working for me today now, thanks!

1 Like

Mine is working too. Thanks Zwift.