Speed not correct for watts - Resistance seems too high?

After one year with no problems, now my avatar is not moving as fast as it should be for the watts (and w/kg) I’m putting out. I’m on the Tron bike, and can’t keep up with the C pacing partner group that I ride with all the time. It’s a 2.5 w/kg pace, and I’m putting out 3+ and falling out the back. I can usually hit 42 kph on a flat tarmac road with about 3.2 w/kg, but now I can’t even hit 35 kph with that power.

I usually use Apple TV, but yesterday I used PC in my last ZRL race so I could switch bikes (to the Grail for the dirt). So it now seems like it’s ‘stuck’ on the Grail resistance even when I’m on the Tron bike. I’ve switched back and forth, restarted everything, still problem persists. Help?

My first thought is force close zwift or turn off the apple TV to make sure you are fully logged out.

1 Like

Thanks Mike. I tried that, but now I’m going to unplug it and fully restart.

I’ve solved this issue. My game instance from the previous night (with the grail bike) was still ‘stuck’ open on the Companion App. Once I closed/saved that, everything worked fine.