[solved] Another BKool Pro Connection Problem


(Craig Ball) #41

Followed these post as I have had the same issue with my Smart Pro, tried the old 3.50 and the 3.53 updated version but the elusive Ant + FE-C option still isnt showing in pair devices on the Bkool simulator, anyone any further ideas? Thanks, Craig 


(Phil Hasell) #42

Craig.  I have the same issue.  Do you have the Bkool version (rather than firmware) 3.02 or anything lower than 3.06?  If so here is Bkools response

 

"Thanks for your message. Only those Bkool Pro updated to the 3.06 or later firmware version can be used with any other simulator compatible with the ANT+ FE-C protocol. You can know your firmware’s version by clicking on the simulator’s Settings button, at the top of the screen. Down in the menu you will find “About the App”, and if your trainer is paired, you will see the firmware version that it has in the Sensors section.

If the version is 3.02, the trainer cannot be updated to ANT+ FE-C protocol as the electronic card was not designed to permit this feature. Sorry in that case. "

So nothing that can be done apparently!

But they di sign the email off “See you at BKool” so everything is rosy!!!

 

 

 


(Rob Hayden) #43

There’s a version of the SmartPro hardware that can’t be upgraded to firmware above 3.02?

I thought bkool already supported FE-C before the first SmartPro was launched. 

I do actually like, or dare I say it prefer, some of the bkool simulator features but not having the Zwift option would be a real shame.


(Phil Hasell) #44

It’s weird Rob.  I am able to upgrade the firmware but apparently the version (rather than the firmware) 3.06 or below presumably can’t support it.  I don’t really understand but the info above is a direct quote from BKOOL. 


(Jason Hemingway) #45

Hi whats the latest firmware for the BKool Smart Pro 2, my version set up today says sensors v3.19 (ant), the BKool indoor software is v3.52 so dont know if i have to change anything as in previous posts?


(Rob Hayden) #46

Yeah I’ve got 3.19 too. And I’m using the 3.53 beta. It doesn’t prompt for any firmware update. And I think the (ANT+) only appears on the trainer name once it is switched over to use FE-C so yours sounds like it should be working?


(Jay Hemingway (Condor RC)) #47

Cheers Rob, did the 3.53 beta download and had no problem finding Ant+ Toggle and also rode zwift faultlessly this morning. Cheers


(Andrew Jarvis) #48

Thanks Rob - just put 3.53 on Mac and it has updated to 3.10 - not only that but seems to have added BLE capability - winner!


(Maurice Rosales) #49

I used the 3.53 beta that Rob posted last night and I (finally) got the the famous button to enable ANT+ FE-C for my Smart Pro 2!

Someone asked about firmware - my Smart Pro2 is 3.19(ant) and I bought it in Nov. so it’s pretty new.

There appear to be several ‘fixes’ in 3.53 (according to some of the release notes) so looking forward to the production release

As a side note I installed it an a VM (on the same notebook) so that I didn’t need to uninstall 3.52. The VM worked fine with the dongle etc. (certainly good enough for this purpose).

 

 


(Andrew Jarvis) #50

Having said that BTLE was enabled on my Smart Pro after the 3.53/3.10 upgrade - it will not allow Zwift to see it as controllable - just as a power device. From another discussion I have seen on here, this is due to Bkool using some proprietary BTLE commands that they have not shared with Zwift - I have asked Bkool if/when this will be sorted but no answer… it’s a shame as it can now be seen on iOS but only as partially smart. Will post anything I hear.


(Rob Hayden) #51

Yeah I was going to ask about that. I don’t think BTLE has a standard protocol like FE-C so each simulator has to write a driver for each trainer. Not really bkool’s fault but Zwift haven’t added support for theirs yet.

Don’t know if it’s actually documented properly though so it might be bkool’s fault :wink:


(Leif Döring) #52

Hi,

I managed to get that famous button using the upgrade. Well, this worked in bkool and also the simulator still works. But Zwift refuses to see the Ant connection.

Anybody had the same problem?

 

 


(Rob Hayden) #53

Have you closed down bkool? The connection to ANT+ gets blocked by any app using it.


(Gary Pritchard (L2P)) #54

Thanks so much Rob the beta version worked a treat. Can now use bkool on zwift


(Chris Gorney) #55

Just talked to Craig with BKOOL USA. New version is coming out this next Tuesday. BKOOL decided to just wait until new version was ready rather than just sending patch. There is a pre-release version available if you email Craig at charrison@bkool.com.

He is sending it to me now. I have yet to try it but am hopeful. 


(Andrew Jarvis) #56

That’s good news - so this is Firmware for the trainer then? I have 3.53 beta installed which brought BTLE to my Pro v 1… but still not Zwift… fingers crossed!


(Andrew Jarvis) #57

Any news on this at all (BTLE controllable)?


(Kayak Elite) #58

Hello, still no news for iPad (Bluetooth control). Hope a prompt fix up. Otherwise will go to Tacx.


(Ignacio Fores) #59

Now I installed the 3.50 version and the system does not allow me to run it. Either I upgrade (to the version that doesn’t work) or it quits…