[solved] Another BKool Pro Connection Problem


(Dyna .) #21

Yeap same, status. 

 

Found here old version of Android apk : https://www.apkmonk.com/app/com.bkool.simulator/#previous

I’ll try to emulate Android on my Mac, maybe not today, if you want to try. 

 

 


(@ speedportraits) #22

I did try the android thing but the installed program seems to have to go off and find some sort of data file to download and on my device it can’t find it and crashes.

It sounds like Bkool are on the case and we shouldn’t have to wait too long though!


(Rob Hayden) #23

Yeah I think I’ll wait rather than mess with Android emus. Annoying but bearable for a few more days.


(Bart Verreyst) #24

Hey everyone,

I have received a mail of Craig Harrison BKOOL Brand Manager USA 

Thanks for the message.

We found a bug in the latest simulator that omitted the FE-C button. The programmers are working on it, but I don’t expect a new version with it fixed until next month.

I do have a workaround, however. It involves installing an earlier version of the simulator, going into the pairing menu (where the button should appear once paired). Once you do click on the button, you just restart the app. You should get a prompt to update back to 3.52 and you’ll be all set.

Currently, this has to be done in Windows only. I’m waiting on the Mac version

https://s3-eu-west-1.amazonaws.com/bkool.com/game/bsim2setup_3.50.exe

Please let me know if you have any trouble.

Just out of curiosity, what country are you from? I’ve been getting emails from all over.

Thanks for your patience,
Craig


(Rob Hayden) #25

Great. Thanks. … maybe I’m being paranoid but it’s been quite a week for IT security. I think I’ll email Craig to make sure that was from him. Especially as I think the bkool indoor app isn’t signed code.


(. LeahShaner(RWB LEAD)) #26

I got a Bkool Pro 2 for Christmas and I have the same issue with Zwift not pairing up with the “controllable device”. I am running v. 3.52 on a mac and it does not work. I hope there is a fix soon. Please keep posting updates. Thanks!


(Rob Hayden) #27

Ok I scanned that file with a few things and it came up clean so I went for it. And it is actually signed code, so seems legit to me.

 

It asks if you want to upgrade as soon as you run it of course, you just Cancel that first time.

Button appeared on cue. All good!

Thanks a lot Bart


(. LeahShaner(RWB LEAD)) #28

Great news! Now hoping the Mac fix is on its way!


(Rob Hayden) #29

If you know anyone with a windows laptop, get them to bring it round (or take your trainer and ant+ dongle to them), it’s a one-off job, you can then go back to your Mac for the actual training sessions.


(@ speedportraits) #30

I downloaded he Bkool app from Craig (thanks) and after uninstalling 3.52 installed 3.50.

All worked fine and did the FE-C protocol thing and now my Bkool Go is paired with Zwift and seems to work fine.

Hooray!!

 


(. LeahShaner(RWB LEAD)) #31

I downloaded file to Windows successfully, BKOOL software opens, but devices are not pairing. Even with dongle right smack up against the trainer. It just keeps scanning. Hm… so close!


(Rob Hayden) #32

Were they pairing under 3.52 before? If so have you tried removing and re-adding them? (Or was that on your Mac?)

I have the dongle about 2m from the trainer and that’s fine for me. I have had problems, while doing all this messing about, where it didn’t show up until I started pedalling though.


(Dyna .) #33

Hi ! 

 

Work well on mine. 

I’m also in touch with Bkool in order to have a Mac Version, as soon as I have news, I tell you !

 


(. LeahShaner(RWB LEAD)) #34

*UPDATE* I was finally able to get the ANT+Fe-C after running Windows 10 on my Mac, downloading the file for v3.50, installing the software, and opening settings. And there was the elusive button! Clicked on it and was then able to pair controlled device on Mac OS side.


(Phil Hasell) #35

HI.  Where is the execute button meant to be.  I had the same problem and uninstalled 3.52 and installed 3.50.  The device pairs but still no button


(Rob Hayden) #36

You can’t miss it, it’s right next to the “-” button that removes the pairing for that device. Worth trying to remove and re-add it a few times I’d say. I had the ant+ dongle quite close to the trainer when I did it. Less than 20cm away. If it doesn’t appear under 3.50 and it’s definitely not already enabled, then I don’t know what’s going on.


(Phil Hasell) #37

Thanks Rob.  I have actually got the dongle on a 3 m USB extension to cut out noise so its literally next to the trainer.  Hey ho one for Bkool support

 


(Rob Hayden) #38

Hi

Good news, BKOOL sent me a link to the 3.53 BETA today which is supposed to fix this.

I already downgraded to 3.50 to do the FE-C switch so I can’t test it and I’ll probably wait for the full 3.53 release now, but there are Mac and PC versions here in case anyone wants to try them. They said you have to uninstall 3.52 first.

PC: https://s3-eu-west-1.amazonaws.com/bkool-public/3.53/bsim2setup.exe.zip

Mac: https://s3-eu-west-1.amazonaws.com/bkool-public/3.53/BkoolIndoorInstaller.pkg

Cheers

Rob


(Pelayo Rodriguez) #39

Hi guys, 

 

i have just tried the version Rob posted on a Mac, and it worked me…

Thanksss!

 

Pel


(Laurence Doddy WBR D) #40

Posting from the UK here. The Windows version has enabled me to finally pair my Bkool Smart Pro 2 with Zwift. Haven’t done a ride yet - will see how it works tonight.