[solved] Another BKool Pro Connection Problem


(Ringo Rohe) #1

Hey everyone.

I bought a BKool Pro (new, not used) 2 Weeks ago and am not able to connect it to zwift as a controllable device via ANT+. It is only possible to establish a Connection over Bluetooth as Power Source and Cadence Device. I am using the Zwift App on Mac OS 10.12 and have read the Threads about the Software Update of the BKool Trainers. My Trainer hast SW Version 3.16 what should be the latest as far as I know. Also there is no Button to enable ANT+ FE-C or something. The BKool Simulator Software works well. What can I do?


(Geoffrey Easton ZHR G) #2

Did you purchase it direct from BKool on an instalment plan? If you did then I believe the ANT+ FE-C upgrade is not available until it is fully paid off.


(Ringo Rohe) #3

No, I bought it from a retailer in Germany and paid full. No instalment plans or rental or something like that.


(Steven Gilbert (PACK)) #4

I have a BKool Pro with the same version. I can’t remember exactly how I enabled ANT+ FE-C mode in the BKool software, but it is definitely in there somewhere. It’s not quite the same as the threads on the topic (they seem to have changed the software slightly), so keep persisting. BKool haven’t made it obvious if I remember correctly.


(Geoffrey Easton ZHR G) #5

When you refer to “SW version 3.16” do you mean the BKool PC app (which I think is currently v3.40 though I cannot confirm as I uninstalled it 18 months back) or the firmware of the unit? This must be at least v3.06 to support ANT+ FE-C protocol.

In my case I got in touch with BKool support who, surprisingly, were very good. My unit was permanently stuck on v3.02 and so they remote controlled my PC whilst the unit was connected to try and force the firmware update to v3.06 through. That failed but that’s another story; I ended up having to send the power unit back to Majorca where they changed the circuitry…all at their expense!

So I would get in touch with their support to see if you can get any joy. 


(Ringo Rohe) #6

Thanks to all. I got it working.

After several times dis- and reconnecting the Trainer in the Pairing Menu in the BKool Simulator Software, I finally got the Button to enable ANT+ FE-C. I have no Idea what I’ve done different this time but after some tries it popped up like a miracle. :smiley:

It’s now fully working and controllable by Zwift.


(Sander Tielen - Lamachine.cc) #7

Hi everyone, I’m still experiencing the same issue as described above. Using a Bkool Pro 2, with Bkool Simulator 3.52 on a Mac Book with MacOS 10.10.5. Don’t see the button in Bkool Simulator. Tried Bkool customer service they just claim that the button is there when it in (my) reality isn’t.

Anyone can help me with this issue. Bought it for use with Swift, this way it’s useless. 


(Ringo Rohe) #8

If I remember correctly, the button only appears when the trainer is NOT paired.

Try to pair and unpair your Trainer a few times and the button should show up.


(Sander Tielen - Lamachine.cc) #9

Thanks Ringo, I’m using 3.52 BI software and for some reason I think they screwed up the software or something. It’s not the computer. I’ve tried MacOs (two different) and a Windows. Paired and Unpaired like a million times. With none of these options the button shows up. I’m fed up, spending two nights trying to solve this. It’s going back to the store I’m afraid.


(Rob Hayden) #10

Hi - I have the exact same problem as Sander with a Smart Pro 2. Been messing around with this for 2 days using a windows10 laptop. No F-CE button using latest version of the bkool software.

I quite like the bkool simulator (even though it crashed twice in one evening which is shoddy and gives a hint towards why this miraculous button is reluctant to show up) but obviously want to get zwift working.

I’ve logged a support ticket with bkool but I’ll keep trying to re-sync it in the meantime while stirring some chicken bones or something.

Quite like the trainer itself.


(Dick Smit) #11

Software version 3.50 will show the button, 3.52 won’t. Good luck finding 3.50…

I managed to get a copy of 3.50 from my brother. Now I’ve spent the last two days trying to update the firmware. No luck so far.

At least now I can get it to work with Zwift via ANT+, although I want firmware 3.10 because I understand that will enable Bluetooth.

 

 


(. SiSeymour (C)) #12

Similar issues trying to get Bluetooth to work on zwift for iOS (iPad).  

I have a new pro 2, which connects to the Bkool simulator via Bluetooth ok. It was picked up as an available device in the scan.  On the simulator home screen bar, you can see it’s connected to Bluetooth by clicking on the radar icon ((( ))) . I did a quick trial and it seems to change on the hills in the simulator automatically as advertised

The problem isn’t that it isn’t picked up as a ‘controllable’ when logging into zwift even though the Bluetooth is evidently working, which defeats the object of me upgrading to a smart trainer for zwift!!  I haven’t set up or tried Ant+, as that requires connecting to a computer, which although more powerful, lacts the ease of iOS.

zwift can see the trainer for power and cadence, but the calibration is way off so this doesn’t work as a solution for racing.


(Rob Hayden) #13

Zwift say they don’t support it over bluetooth - is that a recent change then? Firmware on mine is 3.19.

Thanks to Dick Smit - I’m going to try to sync mine up with a friend’s laptop as I think he might have an older version of the Simulator as he was able to get Zwift working.

These bkool guys need to get their act together, it’s farcical.


(. SiSeymour (C)) #14

All seems a bit Betamax v vhs, but seems you are right: “Bkool uses a proprietary Bluetooth protocol and will not work with Zwift over BLE at this time”. Shipped firmware is 3.52. I’ll try on Ant+. Just doesn’t have the ease of BLE on iOS


(Rob Hayden) #15

Got a reply from bkool support saying they are aware of this bug with the button not showing up and are working on it. I’m going to try my trainer on my friend’s older 3.5 installation tonight.

 

btw, it’s not my firmware that’s 3.52, it’s the simulator software. My firmware is 3.19 - anyone know what the latest is?

 

And I tried BLE but it just shows as a power meter on that, not a controllable. I think probably everyone knows that already.


(Simon Painter) #16

I’ve got the same issue with the enable ANT+ FE-C button not present so I can’t use zwift. I’ve also contacted Bkool and was told that they are working on this known issue. It would be great if they could give us a link to an older version until they sort this out. Their simulator is OK but it feels a bit lonely compared to the rider filled roads of Zwift.


(Dick Smit) #17

Sounds like I won’t get what I’m after even if I do get the firmware upgraded… it needs to be controllable over Bluetooth.

I noticed riding that the resistance is definitely controlled but the watt readings required me to work a lot harder than when I used a dedicated power meter before (garmin vector). I’m reading here and in other threads that people aren’t happy with the calibration of the BKool trainer.


(Rob Hayden) #18

Argh my mate had updated his software to try to solve a different problem he had on Saturday!

Have to wait then. I’ve asked bkool if we can have the 3.50 build in the meantime. And also why my green light now doesn’t light up!

As for power, seems OK to me over ANT+ compared to my ELSA RS in the real world. I get similar simulated speeds at similar power output. Maybe slightly higher (accurately thanks to the lack of wind resistance)


(Dyna .) #19

Any news from BKool ? Same problem here, same answer from support, but no news…


(. SiSeymour (C)) #20

From bkool this am. May be what you have…

“There is currently a bug in the simulator and the blue button to change into ANT+ FE-C is not being shown. Our software/web developers are currently working on it, it will be fixed in the coming days, in the next simulator’s release.”