Setting Zwift up with a Tacx BlueMatic T2650 Smart Trainer

(claire vincent) #1


I have just bought my first trainer. I think I have put the speed and cadence sensors on the bike correctly. I don’t know what to do next to connect to Zwift!

Can you help?

Many thanks

(Paul Allen) #2

Are you going to be using a PC, Mac or iOS device?

(Paul Allen) #3

(claire vincent) #4

Hi Paul

I’ll be using a Mac


(Paul Allen) #5

With a Mac you can use the built-in Bluetooth or an Ant+ dongle to connect the trainer to the computer. Download the Zwift app onto your computer and start it up. When it gets to the pairing screen make sure you are pedaling to wake up the trainer and speed and cadence sensor (and HRM if you have one). I would recommend reading this to help you get started: 

I would also recommend downloading the Zwift Mobile App onto a phone so you can control turns, give Ride Ons and other cool things.

If you need addition assistance let us know.

(claire vincent) #6

Thanks Paul. When I go on the Tacx app, it shows it is paired via bluetooth but Zwift cannot find it when searching. Both the ANT and phone icons in the top left have an exclamation mark next to them. I tried to connect when pedalling but it didn’t make any difference. Do you think I need a dongle?

Thanks for your help

(claire vincent) #7

Bluetooth icon now working…but not ANT

(Paul Allen) #8

Bluetooth can only connect to one app/device at a time. Disconnected it from the Tacx app and restart Zwift and try again.

(claire vincent) #9

Hi Paul

Bluetooth is working (I needed to switch if from Zwift mobile link) but no luck with ANT. Do I click on power source on the Paired Device screen or Cadence. I had no joy with either to be honest

(Paul Allen) #10

Do you have an Ant+ dongle in your computer? It’s not needed with a Mac.

On the Paired Devices screen click on Speed Sensor + Classic Trainer, you trainer is a supported classic trainer so it will show on the list.

(claire vincent) #11

No I don’t have a ANT+ dongle.

No list is appearing. When the Paired Devices screen appears and I click on Speed Sensor + Classic Trainer (or any of the other options) a pop up window appears that says ‘Searching’ at the top and the rest of the window is grey. No list appears

(claire vincent) #12

(Paul Allen) #13

Make sure that the trainer and/or the Speed/Cadence sensor is not connect to any other device before trying to connect it to Zwift.

What is the distance between the computer and the trainer? 

(claire vincent) #14

Yay! That seems to have connected. Many thanks for your help

(Paul Allen) #15

No problem, glad to help.

Ride On!

(claire vincent) #16

Sorry, Paul, one last question. If my computer needs to be very close to the sensor for Zwift to work (and where it’s difficult for me to see), can I extend the range with an extension lead?

(Paul Allen) #17

That is the recommend solution for Ant+, but if you have a USB extension and a Bluetooth dongle I would give it a shot.

You could connect your computer to a TV using HDMI or any other way and use the Zwift Mobile App to enhance your experience.

(claire vincent) #18

Many thanks

(Jason K) #19

Thanks for helping, Paul! :slight_smile:

Since this is resolved, I’m going to close the thread.