Screen Capture only captures background

(Mathew Bittleston) #1

When using F10 to take a screen capture, it has recently (since about July 14th), not been including any of the foreground (statistic boxes, list of riders, wattage, map etc.) The picture looks almost the same as the _clean version. One of them is usually brighter though.

It seems to be a bit inconsistent, because a week or so ago I tried to get a screen capture of the ride report, and all it recorded was a clean picture of the road etc. But on 7/26 it did actually record the ride report.

Incidentally, it also seems to be recording two files every time now (the regular file and with the _clean suffix). But neither have any of the foreground information.

I’m on Win 10, and run Zwift in full screen mode.

(Kranked Team CLS) #2

I am also having issues. What happens is all screenshots within a group ride will have the data missing (no power, cadence, HR, no chat window, no KOM boards). They also appear as 2 copies sometimes, one is a version that looks super dark and the other is the usual “clean” version.

However, i can capture a ride report with all the data. When starting a new session and clicking “watch mode” and leaving avatar in idle/following another rider, all the data is there when i hit f10.

I had a blue screen a few weeks ago when i tried to calibrate the kickr after a long session. That seemed to have reset preferences to default. That’s about when the screenshots issue appeared. Win7, full screen.

(Vincent W.) #3

Hey Matthew, are riding with a friend or participating in some kind of group ride when you’re taking these screenshots? 

K ranked, have you tried taking screenshots in a solo ride to see if you get these “clean” snapshots again? 

For both, where were you two riding when you took these screenshots? 

(Kranked Team CLS) #4

Watopia, London and Innsbruck. I will have to check a proper solo ride as i usually do group training rides. Judging by the date on the screenshots the issue started around july 15th.

(Mathew Bittleston) #5

@Vincent: No, it’s been a solo ride every time - and Watopia almost every time except Innsbruck on 2018-08-06 (I set zwiftprefs to only go to Watopia usually).

I’ve attached thumbnails of my screen captures. Looks like the last time it got the whole screen was July 12th. Notice that some of them are really dark, some are white, and on 2018-07-26 it somehow got _only_ the foreground that’s missing in all the others…

(B r.a.d.l.e.y.In.Kona) #6

I’m getting the same thing as  Mathew Bittleston… no overlay on screen captures and dark versions of screen captures side by side with normal brightness ones. This happens on solo rides and races, like at the end when I want to get a screen shot of the leaderboard/results. Super annoying. Seems like it worked OK a month ago. Doesn’t matter which map/world I’m riding in. I’m running Windows 7 x64, GTX950, 48GB RAM, 2560x1600 monitor with max res in Zwift, “high” rendering detail.

(Vincent W.) #7

Hey all. This is a verified issue that’s been happening for a little bit that we’re still investigating. I’ll update the Known Issues list to include it. Thank you all for the detailed responses! 

(Timothy Williams) #8

Hello all,

I am seeing the same issue (on a solo ride, using a Win 7 PC and the F10 key), but it looks like it is now in the KIL. Thanks, Vincent, for your work on this issue!



(Mathew Bittleston) #9

@Vincent: Is there a workaround? I’ll try using the windows game bar.

(Vincent W.) #10

Doesn’t seem like it Matthew, unfortunately. I’ll keep you all posted when I get updates :) 

(B r.a.d.l.e.y.In.Kona) #11

Apparently the workaround is to set your image upload options to “Never”.  I tested that yesterday and the F10 screen capture worked, including the overlay info.  

(Kranked Team CLS) #12

Hmm now that you mention it…probably was how i set the uploading and it got set back to default when i BSOD. Will check it out but i’m pretty sure you’re right Bradley!

(Mathew Bittleston) #13

@Bradley: Yes, I just tried it. That works for me too: Image upload “never”. Thank you.

(Timothy Williams) #14

Yeah, same here. Thanks, @Bradley!

(B r.a.d.l.e.y.In.Kona) #15

I have to give credit to James Hodges (from for telling me about the workaround in response to my post in the “Zwift Racers” Facebook group.  Funny thing is I meant to post in Zwift Riders! Oops.