Scotland Nationality missing?

For some reason my nationality has changed to ‘blank’.
In the pulldown list on the profile page (which is strangely ordered in any case), there is no longer an option to select Scotland, only UK and Wales.

I have tried in both Safari and Chrome.

Anyone else know what’s going on there?

(On another note, the hoops you need to jump through to get to email support are crazy now, I gave up)

Does it let you change it in the ZCA ?

Strangely it’s already set to Scotland there, and I can set it again, but it doesn’t reflect into Zwift or ZP

Rediculous situation . Zwift were informed about this bug at least 9 months ago and are as usual just ignoring it . Thankfully you can still set it through the companion app . But there is a slight issue as the companion app doesnt properly support all profile options … :roll_eyes: :cry:

So what you have to do is

On Web portal make changes and set your country to Antartica or whatever .
Then open Companion App and set it back to Scotland.

Support here is shockingly bad . Such a simply think to fix cant be done for months and months . No wonder it takes years to do anything more involved than this restoring a record to a data source.

Thank you - I never thought of setting it to ‘something’ in the web portal first… seems to have worked!

Agree - not sure why support isn’t dealing with these kinds of things.