Saris H3, ATV Bluetooth dropout

@Rob_Mitchell , my interpretation is most of those currently participating in the thread are using the Apple TV unit.
This thing is absolutely witchcraft. Yesterday I thought I would try the power cycling trick on the APTV. Did a ride and everything worked fine. This thing is totally random in its effect/s and thus is going to be mission impossible to diagnose for the software folks involved. I think all we as users can do now is keep this thread alive and hope it brings sufficient attention for the developers involved to chase this ghost.
While my belief is this problem rests with Apple I am a bit disappointed this thread is now 141 posts long and nobody from Zwift has weighed in with an opinion.

Have you raised this issue with Zwift support and specifically pointed them at this thread? That’s more likely to gain a Zwift opinion.

@Steve_Hammatt You’ve asked this question and its already been answered.

Sorry, but in a thread this long I didn’t remember that. I’m not sure why you’re expecting Zwift to respond in this thread though, based on experience of these forums. They only post in a tiny minority of threads.

I didn’t say that I was expecting, I said I was disappointed.

I have officially downgraded TVOS to v.13.4.8 (the one that other threads suggest worked before all the current problems). Latest Zwift version and latest H3 firmware. I only did a short ride today and had not issues, but I will report back on my experiences over a period of time. While it may not provide a direct solution for those with ATV 4k, it might help identify the source of the issue.

Congrats Lou, hope that works for you. Looking forward to hearing how it goes.

Status update after downgrading TVOS. Have had three straight days with no BT drops. One of the rides with Tour de Zwift with 1,000 riders - notorious for previous drops - no issue. Today, I tried to throw everything I could at it. Paired H3 and HRM with ATV. Also paired H3 with head unit via ANT+. Connected Stages PM to head unit via BT. Ran iPad with companion app and Discord and BT ear buds. Not a single blip.

One thing if you have ATV 4 and are considering downgrading. Before downgrading, I turned off auto software updates on the ATV to avoid it upgrading on its own. After downgrading, I didn’t check to see that auto update was still off. Overnight the ATV auto updated to 14.4. So, i downgraded again and immediately went into settings and turned off auto updated. The ATV continues to tell me there is an update, but I ignore it.

Last thing, when you downgrade, most apps continue to work. There are some, however, that won’t load. Netflix for one. From research, it seems to be because the TVOS is not up to date. Hopefully, Zwift continues to work despite version upgrades.

@Lou_Glaser Great, sounds like you’re getting the wrinkles smoothed out of your operation.
I do have an update of sorts. I couple days ago I just didn’t feel like dragging my laptop down to my pain cave so I fired up the APTV and started a ride. I knew right off the bat that the witch was back and had bad resistance latency. I just said screw-it for most of the ride but then I noticed the data showing on the Companion App was not agreeing with the game at all. So just for giggles I swipe closed the App on my iPhone and poof, the latency issue went away! So I finished that ride, cranked up another with the Companion App completely closed and the ride went perfect! This is a bit bewildering as I have always had the BT bridging on the Companion App turned off and paired my devices directly with the APTV. But as an experiment I went into the settings section of my iPhone and to the settings specific to the Companion App. Even though the BT bridging was turned off in the App BT was still enabled in the App settings so I turned it off. Additionally I turned off “Use Cell Data”. So after doing all this I paired things up with the APTV and started a ride with the Companion App closed. After riding for awhile I opening the companion App and all was good. I ran through Titans Grove which is always a good test and everything went perfect. Now this may well be just another chapter in this never ending saga but I will continue to test this and report in later in the week.
PS: Companion App version 3.21.1 (1084)
iPhone is running 14.4
Latest iOS version on APTV and Latest Zwift version

While this is one way to do it, as a best practice, I would recommend you put your iPhone into Airplane mode whenever you Zwift.

In addition, always force quit Zwift and the Companion app after each Zwift session.


@Lin_Alan Thanks for the idea on “Airplane Mode”, I’ll give that shot.
I have been making it a practice to swipe/force close the Zwift on APTV and the Companion App at the end of a ride. But, that said I may have had the Companion App up and running on my phone before pairing the H3 and HRM with APTV when starting a ride. So hereforth get everything paired up with the game first, then introduce the Companion App and we’ll see how that goes.

I get Zwift up and running. Then, once I’m pedaling, I grab my phone, put it in airplane mode, fire up Apple Music, and start the Companion app.

Will do that this week. :+1:

I have a good streak going right now. I used my MacBook to complete all TDZ stages but have gone back to my ATV for 4 rides all over 30 miles without any lag or BT drop. I haven’t changed anything on my ATV, iPhone, HRM or H3 and I am streaming music from my phone to the ATV. All I do is restart my ATV before each ride (saw this suggestion earlier in the feed and thought I would try it). Go to Setting, Systems and Restart. Last night I rode 45miles which lasted almost 2.5 hours without an issue. I’ll try again tonight and hope this will be ride #5.

1 Like

I had 4 days with no drop out cyber blue tooth flats! It’s a zwift miracle.

These rides involved the final zwift tour slow ride Tuesday, Wednesday Toronto TT race and zwift repeat final stage faster paced, Saturday climbing race and 2 zwift make up climbing stages on Sunday (I did not need them, just liked the course and did them as endurance effort).

I did have some strange resistance at the start of LaReine yesterday where it felt much harder on the flat part than normal but did not feel that on my second ride yesterday.
I don’t think I did anything different but the ipad may have taken an update on ios version.
I usually start my zwift (ipad) and companion (iphone) at the same time without giving it much thought.
This reply won’t help but always good to read of less problems.

Well, that didn’t last very long, 47 minutes into my ride and lost connection. Had 4 good days without any issues and last night same issue with loosing remote and then the H3. It sucks especially when you’re having a good ride. I’ll just use my MBP until an update comes out for ATV or Zwift app for ATV iOS.

When you or anyone loses connection between the H3 and the ATV what is the LED on the H3 doing? If it blinks green then it lost Bluetooth. If if blinks blue then it has a connection but can not communicate. It could be connected to the ATV or has grabbed another BLE device. In that case you’ll need to force close the app and get that light blinking green again in order to repair to ATV.

What is sounds like to me, and I’m only guessing like many of us, is that the BLE communication protocol between the H3 and Zwift on ATV is a little off or not stable. That could explain the reverse resistance. When ZWIFT or H3 can not decode or keep up with the BLE packets one or the other drops out. It could be that other brands like Wahoo or Tacx have a different BLE protocol that doesn’t cause issues. It explains why various updates initiate the issue because one or the other don’t keep up with changes required to keep both devices talking to each other correctly.

In mine experience, I get the blinking Blue LED. Unless I close out the Zwift app to release the BLE connection, there’s no recovering from it.

The ATV remote loses connection at the exact same time but within a second or two, it reconnects automatically but the H3 continues to blink the Blue LED.

It was always blinking blue light for me. Per the Saris LED light summary of blinking blue: “Often an app on a device has connected to the trainer as a power meter. Some apps will connect to the trainer but not issue a control command, which would also leave the trainer in this state.”

My experience is same as @Joao_Flores - ATV remote disconnect appears on screen and then H3 goes into the blinking blue state. The ATV remote reconnects and works, but not the H3. Only once was I able to unpaid and re-pair the H3 within the game and continue. Otherwise, I had to unplug the H3 and then reconnect. If you look at a Strava graph of power, cadence, HR, etc., you can see the dropouts - both the H3 and HRM drop, so it’s not just the H3. I have one ride where you can see it dropping the connections, reconnecting a couple of times and then finally failing. As set forth in the Saris LED summary, Zwift is connected (and shows the H3 and connected) it’s just that nothing happens - Zwift does not display any power, cadence or speed.

Update on my downgrade of ATV to v. 13.4.8. Ten straight days of riding with no BT dropouts. Rides have included free rides, meetup rides, a workout and two Tour de Zwift event rides. Rides have ranged from 50 to 90 minutes and in the case of one TDZ event, 1,000 riders. Last 6 rides have all been with H3 and HRM connected to ATV and simultaneously Stages PM connected to head unit with both BT and ANT+ connections, as well as iPad running companion app, Discord and music, listening with BT earbuds. So, lots of things to interfere with BT connections.

During one ride, I noticed the ATV remote disconnect pop up on my TV and I thought all the luck was over, but the H3 never disconnected.

Lots of great details here Lou! You do have ATV 4K, correct? When Apple updated from 13.4.8 to 14.0 there were lots of changes. Between 14.0 and 14.4 (I believe is current) not as many. It could be that Saris did not keep up with Apple so the changes in their BLE protocol cause ATV to choke, reset its BT, and then the H3 comms are lost; blinking blue (radio is connected but communication is out). The ATV remote repairs but the H3 does not.
I am using a Saris Hammer Cyclops, which I ASSUME uses the same BLE protocol as the H3, without issue, The word assume is what gets us into trouble. Just a thought if you are so inclined, make sure your H3 software is up to date by pairing through the Saris app and then try version 14.0 on your ATV 4K. Or just continue with what you have and makes sure auto updates are off.