Rides no longer syncing with Apple Health Activity

I’m using the latest version of Zwift and Zwift companion (Zwift on AppleTV, Companion on iPhone + AppleWatch).

My rides used to get added as workouts on the Apple Health/Activity, but they no longer do so. Any ideas? This seems to have started with the Zwift update last week.

I am facing rhe same problem. Hope Zwift can resolve that problem soon

I have the same problem. It appeared the first time on April 27th after the Zwift update. The next time the ride was synced to Apple Health, but all later rides weren’t.
Zwift runs on an Apple TV4k, Zwift Companion on an iPhone XR, Hertrage via Apple Watch. Zwift, Zwift Companion, Apple TV OS, iOS and WatchOS are up to date.

1 Like

I have kind of given up at this point and rely on the Strava integration. Honestly, I’m just slowly making my peace that the Zwift Companion app is trash and will just continue to grow more and more useless. The Apple Watch heart monitor connection becomes worse with every Companion update. The Syncing with apple Health is now broken. I’ll just have to hope that the Strava integration does not disintegrate in the future.

2 Likes

Hi @Hugues_La_Ricca @KPAS @Tim_Bellinghausen welcome to Zwift forums.

There are few hoops to jump through to make Apple Health work correctly, which are described at the bottom of this Support Hub article. Would you verify those permissions are enabled?


When you update your OS, it’s possible that your app permissions are reset to their default settings, which can disallow the app permissions that Zwift needs to sync to Apple Health.

Please let us know if allowing the permissions clears this up or not? We’d like to know either way.

Yes, I have all of those turned on in both the Health Settings in the Settings app and in the Health App itself. Nothing has changed in those settings, but I still verified them a few times.

1 Like

My last Companion write to Apple Health was on April 27th and after that the information has stopped appearing in workouts. I have spent multiple hours on the phone with Apple and they have confirmed EVERYTHING on their end is working. My suspicion is that the companion file is no longer being written to Apple Health due to the latest update. I have researched and researched and cleared and updated with every known area and no success. I really hope you can get this fixed.

1 Like

The behaviour was similar for me. The last data that the Companion app wrote to Apple Health on my end was April 23rd. Then there was one on April 30th weirdly enough, then it stopped again.

1 Like

I’m beginning to think that this is more than Zwift and maybe an update Apple pushed but has limited the availability of ZC to write to Apple Health. I also suspect that there are FAR more people that are having this issue but have not found this thread yet.

Absolutely. We can’t be the only ones that keep track of workouts in Apple Health/Activity apps.

I was having this issue too. I ended up deleting the Companion app from my phone, rebooting the phone, and then reinstalling the App from the App Store. I had to allow all the Health permissions for the App, but it seems to have worked. The last 3 rides I did showed up as workouts in Fitness App

I tried that too but something just doesn’t seem to be working with the writing permissions. I have a chat ongoing with Zwift about this so I am hoping it get resolved…

The problem with the Strava integration is the Strava’s calculation for caloric burn varies DRASTICALLY from Apple Health and/or Zwift so it lowers (substantially) the calories burned when you upload the same exact data from strava that USED to come from Zwift.

Calories are always estimated, not included in fit file afaik.

Thanks for the suggestions, Shuji. I already checked the permissions before I wrote here, there were all enabled. I also disabled all and reenabled them, in case the state was somewhat corrupted. But the problem persists.

Just heard back from someone at Zwift. They’ve admitted the last update has errors in writing data to health and are actively working on the fix. Hopefully it won’t be too long.