Problems pair bkool Go / Pro2 Zwift ant+ FE-C app Bkool indoor

Hi Sandy. Thank you for the workaround. Appreciate your effort. I’ve tried several solutions listed below (followed by the outcomes respectively) but it seems I’m still on the bad luck side. Mine is Bkool Smart Pro 2.

  1. Bkool Toolkits (iOS): Pro 2 firmware updated to 3.25. In Zwift the Pro 2 detected as power but controllable not detected.
  2. Bkool Indoor v5.14 (Win10): Devices (Pro 2, powermeter, cadence, speed, hr) connected right away. But cant find the Ant+ FE-C option.
  3. Bkool Indoor v3.53 (Win10) - your workaround: Few devices connected (see attachment). Pro 2 is not detected at all. Hence Ant+ FE-C cant be seen as well.

I’ve been toggling between bluetooth and ant+ for each solutions. Also forced restart the trainer for each solutions. No luck.

Any clue? :frowning:

1 Like

Hi Fateh, the signal strength on the other devices looks a little weak, if you move the trainer nearer the PC does it pick it up?

Oh, and I think it needs to be connected via Ant+ in the Bkool SIM to update it to FE-C

en el paso nº5 para windows cuando dices editar el archivo, dices que cambie el nombre y ponga “version5.14.dat” ¿es correcto?
luego al ejecutarlo se queda cargando y no inicia el simulador.
la verdad no manejo mucho el tema informático.

me puedes explicar como editaste en archivo "version.dat " yo tengo windows, pero al poner "version5.14.dat " luego ejecute el programa pero no me aranca, se queda cargando. y no puedo emparejar dispositivos.

un saludo y gracias de antemano

Sandy, you’re MVP!! It works now. Pro 2 detected in Bkool Indoor, but cant see any form of Ant+ FE-C option though (see attached image). Tried my luck to check on zwift and it is there now. Thanks a bunch!! Will give it a ride this afternoon. #RideOn.

1 Like

Javier, allow me to assist you on this. You will have to edit the content of “version.dat”, not renaming it. To do that, follow below steps:

  1. Right-click version.dat, and select Edit to open in text editor - Notepad. (Note: If Notepad is not configured as the default program, you can open it in Notepad by right-click > Open With > Notepad / Choose Another App > Notepad.
    defaultprogram

  2. In the Notepad, modify the number to 5.14. Save the file and close.
    modify

  3. You shall proceed with the rest of the workaround.

Note: I believe your computer system is in Spanish as well. The options mentioned above may vary. Google Translate might helps.

1 Like

Perfect! I’m just glad to get another person riding in lockdown

1 Like

muchas gracias. lo he intentado y no sé si de forma exitosa, al intentar guardalo, no me deja pues me dice " no tengo permiso para editarlo, consulte con el propietario del archivo o el administrador"
continuo y ejecuto el programa, me sale una advertencia para que actualice a una versión nueva, le doy a cancelar y me dice que el programa no se iniciará pues no está actualizado.
¿ debo instalar esa nueva versión ?

Hi Javi, don’t install the new version of the Bkool Sim as it won’t let you enable the Ant+ FE-C mode.

If you can’t edit the version.dat file then you may need to try another method which just replaces the file with a new one:

  1. Open a text editor (e.g. notepad) and in a new file simply write “5.14” (without the quotes)
  2. Save this new file with the name “version.dat”
  3. Delete the original “version.dat” file from the Bkool Sim installation directory
  4. Copy your new file into the above directory
1 Like

muchísimas gracias. ya lo he realizado todo y con éxito. ahora solo me queda una ultima cuestión, si deseo combinar ambos simuladores, me recomiendas que desinstale el bkool antiguo y me baje el nuevo o continuo con esa versión. no vaya a ser que se desconfigure del nuevo el rodillo.

Excellent news! If you’ve enabled Ant+ FE-C and everything is working in Zwift then you should be fine to update the Bkool sim to the latest version now and use that too.

Hello everybody,

I have got a problem with the ANT connection. On zwift and bkool simulator, when I only use ANT system without bluetooth, my bkool smart pro 2 can’t be controlable by the application (the slope does not change the difficulty of pedaling ) but the others setting are ok ( cadence, power, speed…).
It is not a problem with bkool simulator because I can use the bluetooth but in zwift you must use ANT system for the controlable mode. However I really want to use my bkool smart pro 2 on zwift with an immersive experience.
you can see my setting on zwift with the screenshoot in attachment.

My computer : hp elite book 840
My Home trainer : bkool smart pro 2
Serial number : 32 09 17 73 7C 55 21

I have tried to install the old version like you said on the top, but when I try to find my Home trainer only with the ANT system, my Home trainer isn’t found. But in the same time with zwift my home trainer is found with the ant FEC…

Hi Pierre,

I’ve seen a couple of people with a similar problem to yours but I’m not sure what the solution is yet so it would be good to find one. It looks like you have got Ant+ FE-C enabled since Zwift can see it as a controllable trainer, so you shouldn’t need to go through the steps to do that via the old Bkool Sim.

I just have a few questions:

  1. How far away is the Bkool from the computer? If you move it nearer does that make it work?
  2. If you choose to do a workout in Erg mode on Zwift, does it control the resistance of the trainer or not?
  3. What is your trainer difficulty level set to?

Hello Sandy, thank you for your help during this confinment !

  1. I think 1m but the distance doesn’t change something.
  2. I just tried to do a workout with ERG mode and the resistance doesn’t change.
  3. for this training there is a difference of 123 watts ( top : 250w ; low : 127w).

I did screenshot you can see in attachment.
bkool configuration

Thanks Pierre,

For the trainer difficulty what I should done is pointed you to the actual setting: https://zwift.com/news/4306-zwift-how-to-adjust-your-trainer-difficulty

But since the resistance doesn’t change in Erg mode anyway then something is definitely not working properly and I suspect your trainer difficulty is fine (by default I think it is in the middle)

Since you have a Pro 2, rather than an older Pro or Classic trainer then you might be able to update the firmware. To do this download the Bkool Toolkit app on your phone and connect the trainer - there should be an option to update the firmware. The latest version is 3.25 I think.

I’ve just found a page on the Bkool website about having to ‘unlock’ the Pro 2:

It seems a strange thing to need to do but it involves updating the firmware too. There is also another page which suggests you need to have the computer within 5cm(!?) of the trainer, and also to try turning the bluetooth off:

Hi Sandy,
I have the good version and I did this when I bought the trainer ( 4 month ago). I have the V 3.25.
It is really strange because when I switch off the bluetooth on bkool simulator, i have the same problem as Zwift : everything is ok, I can ride, but the variation of difficulty doesn’t work.94223880_2499491650312195_3295174389246459904_n

thank you from TOURS in France :wink:

That is strange. Have you tried Bkool support to ask why it is not controllable on the Bkool SIM with Ant+? If you can fix that then it might get it working with Zwift

I sent to Bkool an email. I am waiting the answer. Yes I think this is the solution for everything.

Great, I’d be interested to know what they say and if you get it working