Problems after tvOS 16 update [September 2022] [SOLVED]

Yeah, mine’s been doing that for years. No idea why. Merely going into the pairing screen seems enough to kick it in the rump and have the HRM connect.

Tested on several different HRMs over time so it’s not HRM brand or model specific.

As an aside: I know my HRM is active because I have a Wahoo Headwind fan that’s listening for it (over ANT+). The Headwind switches on about 2 seconds after I put on the HRM. It’s only Zwift that seems to ignore it until reminded. (to reiterate: this isn’t tvOS 16 related, per above)

I just spent over two hours banging my head against this after updating both Zwift and Apple tvOS from what was prior a very stable system. Here’s my current setup:

 Zwift 1.29.0
 Apple TV 4K A2169 (gen 2 / 32 GB) running tvOS 16.0
 Wahoo KICKR v5 (paired to Apple TV over one bluetooth channel as controllable trainer, power source, and cadence sensor) 
 Wahoo TICKR X (paired to Apple TV via bluetooth)

Like others, as soon as I fired up Zwift after the updates I received the “Bluetooth Error” notification. Note that my Apple TV remote, which would normally take up one of the actual three available Apple TV BT channels, was NOT paired with the Apple TV, as I always use the Remote app on my iPhone (which works through WiFi) to control my ATV instead of the Apple TV’s BT remote.

I then followed the directions to unpair all devices, then repaired in the following order: KICKR (controllable trainer & power), Cadence (via KICKR), then Heartrate (TICKR X). This appeared to work, but after starting a workout I noticed problems with the Zwift cadence display; every couple seconds it was dropping from ~90 RPM (actual) down to the high 40s or low 50s, then popping back up to actual. About two minutes into the workout’s warmup protocol, during which everything but cadence display seemed to be working fine, the warmup’s target power and my actual power (I was running in erg mode) became uncoupled…my trainer seemed to be stuck regulating the power at 120W while the warmup’s target power continued to rise. The displays on both Zwift and the Companion App workout page confirmed this uncoupling, with the target power eventually rising over 20W higher than my indicated (and perceived) power output, which held steady after rising to 120W and never moved upward thereafter to follow the target as it should’ve. It appeared that Zwift had lost the ability to control the KICKR, and resistance quit changing to meet the workout’s target power, as it should’ve.

I then did a normal exit out of the ride, without saving. Once back at the intro screen I force closed Zwift, then power cycled both the Apple TV and the KICKR, then re-started Zwift. I again got the same BT error and did the unpair/re-pair as before. I then entered a simple Watopia free ride, where everything seemed to be working fine for about five minutes. So I quit, again without saving and this time without closing Zwift, then re-entered from the Zwift startup screen. Even though I’d just successfully paired, ridden, and hadn’t quit the app, I was again presented with the Bluetooth Error notification and had to go through the whole unpairing/pairing process again.

After this I entered a workout and everything seemed to work fine…except for the fact that most of the Zwift Academy 2022 long workouts are missing. So after two hours screwing with this crap, and finally getting it to work, I was again S.O.L. due to Zwift’s poor execution of ZA2022.

I will also note that like one other commenter above, I do NOT get the BT error if my TICKR heartrate monitor is not active at the time of Zwift auto pairing. In that case the Zwift automatically connects to the KICKR as Controllable/Power/Cadence, and then when I activate the heartrate strap afterwards it connects – no errors at all. If, however, I’m wearing the heartrate strap and it’s transmitting at the time of Zwift auto pairing, the power source, controllable trainer, and heartrate signals all pair, but then I get the BT error when Zwift tries to add the cadence portion of the KICKR pairing. This is 100% repeatable.

I use Zwift as a training system, not as some kind-of gamified means of self-validation and affirmation via pretend jerseys, socks, etc, so between the absolute dumpster fire that is ZA2022 and now this pairing junk it’s been a complete fail, and I don’t have time for it.


I’m not sure I understand this bit. Do Tickrs have some special on/off mechanism?

I power up my Neo. Go get dressed, including my HRM. Then I fire up Zwift. As far as I know my HRM is activated by motion detection, and thus active within moments of putting it on. Lastly, once riding I open the Companion app.

UPDATE: Sept 16 @ 22:00 UTC

For those who’ve updated their AppleTV to tvOS 16: please make sure you’ve logged out of your previous Zwift session, and try again. We’ve made a server-side change that has solved this problem for some who were previously affected.

If you’d kindly loop back and confirm / deny that you’re back in business on tvOS 16, that’d be much appreciated, thanks.


…so ‘Solution’ means it’s now okay to update to tv OS16, which I have not done yet? If so, I suggest pinning confirmation at the head of this string.

1 Like

Fixed for me. I’m running Zwift 1.29 an TVOS16 with original kickr and a Tickr HRM. Thanks!


Seems so, but we’d like to hear confirmation from more folks on this thread.

1 Like

Yes, @Lin_Alan that’s correct…you can activate a TICKR X (and I’d guess the TICKR) either by stimulating the electrodes or by tapping it. After you remove it and let it sit for a short time it drops its pairing, quits transmitting, and powers down. So for me if I fire up Zwift auto pairing, get the trainer all paired up, THEN put on the strap (or otherwise activate it), then it’s the last device to pair and everything works.

I think the whole deal is being addressed by Zwift now, though. Good luck!


I’m all good now!


Yes ! Good job Zwift, work`s great again with my Kickr V4 , 4iiii Hrm bridging Garmin Cadence just like before :+1:

1 Like

So what exactly was changed server side? Does this mean it was a Zwift issue? and/or did Apple make some changes that tickled some Zwift code the wrong way?


Confirmed: Back (still?) in business. (ATV4k Gen 1 with a Gen 2 Siri remote.)

I elected for the “nuclear option” after the tvOS update: complete uninstall/re-installed of the Zwift app, adding back login details. My trainer (NEO2T) connected as power/controllable/speed/cadence instantly.

My HRM was actually remembered and paired this time! That’s new - usually have to pair it again each time.

Another data-point: I’m on the old home-screen UI, and the remote 4-way clicky buttons work to navigate menus.

Between the HRM being remembered and the buttons, these are nice quality-of-life improvements.

(edited to indicate the HRM was remembered - that’s a nice new twist)

EDIT 2 - new UI showed up on ATV a few days ago. Things working as they should.


@shooj Sorry for the delay - went away for the weekend.

Gave it a quick try and my problems with tvOS 16 and/or Zwift 1.29 appear to be fixed. I’ll give it a longer test later today and will report back if there are any problems although I don’t expect any.



Hi @Lin_Alan , I’m Sam, an engineer at Zwift. You pretty much nailed it on both counts - there were two things going on here:

  • The tvOS 16 release introduced a change that affected Zwift’s Bluetooth behavior. Previously, Zwift could attempt to “connect” a device when selected, even if it was already connected to the game for another capability (e.g. power, controllable, cadence). In earlier tvOS versions, this was just a no-op, but tvOS 16 seems to have changed this behavior making it much more likely to hit the Apple TV’s max connection limit.

  • We’ve simultaneously been working on improving Zwift’s Bluetooth connectivity and had some changes staged behind a server-side switch, which we were already planning to rollout beginning this week. Among these changes, we no longer attempt to “connect” a device that is already connected. This reduces some unnecessary Bluetooth noise, and happens to also address this issue for tvOS 16 users.

Thanks again to everyone who provided quick feedback to confirm the fix! Happy to hear things are back to working for you all after the weekend :slight_smile:


I don’t think this has been solved yet. I still have problems connecting my Tickr hr monitor. Zwift doesn’t automatically find it and I need to click Bluetooth on and off. Then I can get it connected. I have done everything mentioned above but no success.

Hi @Heli_Laurila . This sounds like a different issue to me. Can you confirm you are not seeing the max connection Bluetooth error that others previously reported in this thread? First, a couple questions:

I need to click Bluetooth on and off.

  • What do you mean by this? Apple TV doesn’t allow you to turn Bluetooth off, are you using another device simultaneously?
  • When did this issue first appear?

To rule out some more obvious potential issues

  • Make sure no other apps/devices in the area are connected to the HRM (you could turn Bluetooth off entirely on phone/tablet/etc. to be safe)
  • Make sure the HRM is on and broadcasting - many HRMs power off automatically to save battery if they’re not being used
  • Does the HRM eventually show up if you wait on the pairing screen longer (say up to 1 minute)?

Thanks for the info.

1 Like

Hi @Sam_Zwift

Yes, I might be wrong and my issue is due to this “ * Make sure no other apps/devices in the area are connected to the HRM (you could turn Bluetooth off entirely on phone/tablet/etc. to be safe)”

I check this out and hope it solves the problems

Thanks for quick reply!


I just used the new home screen on ATV yesterday, overall it’s great but I noticed a couple of things:

My folders are gone in “custom workouts”. This is a big problem, I have 178+ saved. I’m also about to start my off-season training where I get two workouts a week delivered to me, which I place in a folder. I need this functionality back.

My ATV allows me to pair four different BT devices (Power Source, HR, Cadence, Controllable), but then when I start I get a “no signal” alert.

The arrows on my iPhone ATV remote work.


Hi Peter_Hig.

I’m having the ‘no signal’ issue on ATV too - even though the HRM connects ok from the initial power source screen.

Did you get a resolution for the ‘no signal’ issue?


I’m pretty sure that the “no signal” is from the pairing screen allowing me to connect four BT devices on ATV. Once the ride starts, only two BT channels are open.

I recently installed the Wahoo Direct Connect on my KickrV5.
Now I use my Assioma pedals as my power source (BT), Garmin HRM Pro for heart rate (BT) Wahoo Kickr for cademce & controllable (ehternet).