Problem with NEXGIM-MG03 not being able to shift gears

After starting NEXGIM-MG03, the gear is in 04.
When I turn the gear, the display changes from 01-20, but the weight of the pedal does not change, and it is as light as if it were still in 04.
I can’t get up to speed and can’t apply any power.
What can I do to solve this problem?

The zwift app worked fine until the end of December 2021, and I’ve been having individual problems since January 2022.

I’m using the zwift app on my Macbook and the same thing happens on my iPhone.


It seems that if the firmware is old, Nexgim will not work properly after the January update of Zwift.
Check the version in the Nexgim application. If the version is 1.0.1005 or earlier, it is possible to upgrade the firmware to 1.0.1081.
However, even in that case, there will be no response when you click on the firmware upgrade.
If you take a screenshot of the screen where the serial number is displayed and email it to customer support, they will respond immediately and allow you to upgrade the firmware.

1 Like

Thanks for the info!
It’s solved!

My version was 1.0.1005. At the time of posting, it was showing no latest version (already the latest), but when I looked today (2022/01/18 22:00 JST), there was an update.

Just for reference, where can I find information on what may or may not be working?