Prevent Screensaver


(Andreas Gunnerås SZR (C)) #1

When I ride Zwift I repeatedly have to touch the mouse or keyboard to prevent the screensaver from starting (since I have an energy profile to save energy when I’m not doing anything). I’m running Zwift on Windows.

Could this somehow be prevented by the Zwift application instead? (I know there are workarounds like Caffeine (an application)).

The screensaver does not start when i run Trainerroad.


(Jon Mayfield) #2

Andreas, that is an odd one. Zwift has disabled the screensaver when running for almost a year now.  Are you on Win8 or Win10?


(Andreas Gunnerås SZR (C)) #3

Win10


(Andreas Gunnerås SZR (C)) #4

But, I recently had Win 8.1 and had the same problem then. I usually do not run Zwift in full screen, but in a Window.


(Jon Mayfield) #5

Hrm, this is not a common problem at all for Zwift users - but I’ve looked through the code and I see something I can change to improve how this works. Hopefully it’ll sort out the issue for you after the next update goes out.


(Andreas Gunnerås SZR (C)) #6

Great! What a quick response! I guess I have to become a paying user now to try it out since my free trial expired…


(Jon Mayfield) #7

Hi Andreas, I shipped a very small update tonight to address something else but I snuck in the small change to see if it affects your screensaver issue.  Next time you run can you let me know how it goes without you having to mess with the mouse?   We have no way of testing this as the screensaver disable code was working for 99.9% of windows users already as it was, so you’re our eyes and ears on this one. I really appreciate it. 


(Andreas Gunnerås SZR (C)) #8

It seems that your change fixed my issue. I did not need to do anything else then ride on to keep the computer awake. Great! It was only a 1 hour ride and I had some interaction with the computer during that time, so I’m not 100% shure, but I think that I would have entered the screensaver without your change. I’ll let you know if I run into the problem again. 


(Craig Hoskin) #9

FYI … Ive never had the screen saver kick in on ZWIFT (using Win 8.1 or 10) … and I normally have Power saver settings set to have it start after a few minutes.