Power Spikes - Wahoo Kickr Core

Hey,

Bit of background. I’ve been using a Kickr Core with Zwift from Jan '21 until late July without any issues. Then during a particular group ride i started getting what seemed like power spikes, it would correct itself and then the power spikes would return.

Since that ride the power spikes have gradually increased to where they happen every single ride. There doesn’t appear to be pattern to it, it can happen on flat, ascents & descents. It’s never right at the start of a ride but again no pattern, my last two rides it started around the 14 minute mark and then today’s ride around the 21 minute mark. It can last a few seconds to a few minutes.

I’ve upgraded/downgraded the Kickr firmware. Done countless Wahoo app normal spindowns and a factory spindown. Reset the bluetooth on my Macbook, ensured my phone (which is the only other device i have next to me during Zwift) is not connected to the trainer.

Nothing in my set-up has changed at all so it’s difficult to pinpoint anything. It’s now driving me nuts and i’ve obviously had to stop racing as well.

If i could i would attach my latest Zwift fit file but it doesn’t look like i can. I stopped the ride at the exact point the spike happened.

Hopefully someone has some knowledge of this.

Thanks

Hi @Craig_Taylor7, have you checked a log file using zwiftalizer.com?

Hi @Mike_Rowe1 ,

Thanks for the suggestion. I’ve checked previously and again with tonight’s file but to me nothing looks untoward.

Can you post a screen shot?

This was from Saturday. The issue started at about the 24 minute mark into the ride and was on/off from then.

How it visually appears with Zwift. The 3 red surges were the start of it:

what about the graph for bluetooth connections?

There’s no graph for bluetooth connections. The only others are for graphics. Any reason this would be missing?

I’m definitely connecting to the trainer via bluetooth on my Mac.

For me it looks like loosing draft in group rides. I have the same issue, sometimes with Coco 350W isn’t enought to stay in blob. No matter of platform, always in big group ride or blob.

I’am also having spikes when riding alone.

I have a little more info on this. Logged a support call with Wahoo who came back saying that it looks like the Kickr is connected to another device in the background. The only other device in the vicinity of the trainer, other than the Macbook, is my phone and bluetooth is always switched off unless im using it.

I powered down my phone and started another Zwift session on the Macbook. All good for the first 30 mins or so and then it begins to feel like the resistance has gone, I can’t feel the little inclines anymore until gradually some power spikes start appearing.

I managed to borrow an iPad, so after powering down the Mac i started another session (same pace partner course as before) this time it’s perfect, everything felt as it should for the whole duration. I even powered up my phone and had the companion app running with no issues.

So it looks like something is happening between the Macbook/Kickr/Zwift that’s causing this issue. I’ve restarted the Macbook, deleted the bluetooth preference list. But i’m really out of ideas on what to try next.

Any suggestions?