Power Lag/Dropping Out


(Sherwood Plant) #1

I noticed that my power is lagging by up to 2 seconds in the game. I’m not sure if this is power meter related, computer performance, or game issue. I haven’t been paying attention to my HR to compare, but using my Garmin simultaneously seemed to be quite a bit ahead of the game.

I’m not overly worried, as I was mostly doing threshold/tempo work, but it can be an issue for sprints where timing has some impact on your performance. If this is an issue in-game, I hope it is being addressed.

Another thing that happened 2 or 3 times last night was a power drop to 0 for a couple of seconds. Heartrate remained, which leads me to believe it’s not an ANT+ problem, and it’s an issue I’ve never experienced on the road, so I don’t think it’s a PM problem (though it could be, no way to verify).

Windows 7 64bit
Power2Max Type S
Suuntu Mini Stick ANT+ Adapter


(Casey Bersgtrom) #2

One thing to note is that ant+ isn’t the strongest signal. Wireless frequencies cause background noise and can cause interference in your power meter signal. Make sure that you have your ant stick from your computer close enough to you and try and not have a ton of electronics in the area.


(Ramon Hermida) #3

You can also use a USB 2.0 cable extender to bring your ANT+ dongle closer to your power meter. I was having the same issues and the cable has reduce the issue considerably if not completely.


(Janis Lacis) #4

It seams that this issue is still present. I had 3-5 sec. lag. Really annoying :frowning:

P.S. My internet and PC are fast.


(Janis Lacis) #5

Display lag seams to be fixed. Speed, cadence, power is updated with minimal lag.

But… there is a ~5 sec. lag in trainer response to terrain. I noticed it when going uphill in Richmond. There is a intersection where momentarily road flattens out and you get less resistance. Well, in my case it came about 5 sec. late. I use TACX Vortex.


(Derek Graham) #6

Hi, I have a tacx vortex smart trainer as well and have the same issue of this lag, did you ever find a fix?? 

 


(Are Halland) #7

I have the same issue. Constant 4-5 sec lag in power, and 2-3 times per ride I stop up completely, Extremely annoying!

I have a Tacx Flow with a Tacx ant+ dongle with a usb extension, and a fast internet line.

 


(Steve C) #8

There’s a new power smoothing option in the settings - that seems to ‘drag’ out the power increases.

Also, some smart trainers lag power slightly (I guess as they have to calculate from speed/power curves and they need sample data) - so this may accentuate it?


(Derek Graham) #9

I can’t check just now but do you know if that can be switched off? 


(Steve C) #10

Yes - in settings (where you set difficulty, screen resolution etc)