Poor graphics, no details in the landscape

Unfortunately the graphics are very poor on my computer. I have a strong PC with a good graphics card, but there are no details at all, just the road itself.
Could somebody help in the setup?
Could it be because im in the first week’s trial period?

No, can you post the full specs of your PC and graphics card?

CPU: Intel Xeon E3-1271 v3 3,6 GHz
Graphics: Nvidia Quadro K2200
Windows 10

All manner of corrupted and/or broken assets. Reinstall the game properly.

1 Like

This doesn’t qualify as good, I’m afraid. CPU is fine though, so you should consider a graphics card upgrade.


Well, maybe the Quadro K2200 is already not the best, but this is a workstation (actually a server machine) which is designed to run industrial 3D CAD softwares. It’s able to handle 100k 3D elements smoothly and I’m also use it for FEM analysis, so it’s should not be that bad. In other forum topics I can see that details appear on the screen for those who use integrated graphics card.
So, thank you for the helping ideas, but I’m sure that this is not just about the graphics card and the hardware.

It’s definitely not right, but CAD is a totally different workload to games and especially Zwift which relies on brute force. Your card is very slow for Zwift.

update: I’ve changed the graphics card to a Nvidia Gegorce GTX 1050 Ti.
The result is the same. The picture is beautiful, it’s running smoothly but there are no details. It’s runnig on 30% power like the Quadro.

This seems like an installation problem of some kind, or problem accessing the assets that should be installed. If you can’t sort it out by reinstalling, or adjusting permissions, I’d contact support.

Did you reinstall the game?

Yes, I tried to reinstall several times.
Where I have some basic details is Watopia. But in the other areas there are nothing. E.g London. I’ve checked the program folder, and in the Environment folder there’s nothing about London (e.g. buildings).
I checked the possible reasons for the missing folders but everything is OK

  • I’m the administragor in the PC,
  • the document folder is on the PC’s SSD
  • no non-alphabetic caracter in the computer’s name
  • hard drive is OK (checked by SeaTools)
  • firewall is OK (even if I switch it off there’s no difference)

just an example of the building folder:

I suppose there should be some building in London or New York

That path is totally wrong, those folders should be in
\Program Files (x86)\Zwift\data\Environment\Buildings\

Have you manually changed the install path and/or moved files around?

This is what it should look like:

No, it was installed here.
And actually Zwift is writing here without problem.

It wouldn’t surprise me at all if Zwift couldn’t handle being installed on something other than C:. It seems to have all sorts of hard coded paths.

1 Like

Beat me to it. Even if it’s fine on another drive, I bet it can’t deal with \Zwift\Zwift.

Maybe that’s the point! I’ve uninstalled it and installed again on the “D”, but one \Zwift less.
It works now perfectly.
Thank you guys for the tips and a shared picture, it helped a lot!


Crazy that it would run at all in a state where hard coded paths like that exist.