Pebble pounder workout companion app issue [SOLVED]

I’m having an issue with the workout page of the companion app with the new pebble pounder workout. It doesn’t show anything other than an empty meter. No graph, workout steps, timers, nothing. I tried a single workout (ramp test) and it works fine. I don’t want to lose my workouts to this point, so I can’t try loading a different one.

windows 10 and Pixel 3 running latest versions.

Just wondering if it’s me or a bug.


Same for me. Seems to be a few bugs in this new plan. Another thing I’ve noticed is the target cadence is set to zero for warm up/cool down, meaning it’s constantly telling you to slow down.

I’m having the same issues with Pebble Pounder. I’ve done 2 workouts in the plan and the companion workout view has not shown any data either time.

Also seeing the zero rpm cadence targets for warm up / cool down phases.

I’m running the latest releases on PC/Win7 and an Pixel 2 / Android 10.

Trying to attach screenshots - this is my first post, so apologies if these don’t work…


1 Like

Thanks for the reports, all. I’m moving this from the Bugs and Support board to Known Issues.

Our QA team is working on a fix in the next release.

I’m having this same issue. Says o rpm. I can’t do 0 rpm and get in the watts. Confused.

Same issue here. Companion app does not show any details of upcoming workouts and during a workout the app doesn’t show any data. I’ve also noticed the 0 rpm warm up / cool down.

I’m also wondering if some of the workouts are out of order? Week 1 I did SST Bursts 6 followed by Big Gear SST 2x6, but the commentary seems to suggest “Big Gear” should have been the first workout? Looking forward to week 2 it appears to be the same.


Hi @Mike_Pierson1 @Gary_Ledgerwood_PACK and @Klaus_Christoffersen @Jason_Watts
Thanks all for reporting this issue.

This problem was identified and should go away with the next release of Zwift Companion (v.3.6.3). We appreciate you letting us know!