Password field empty on Mac [SOLVED]

hi there, im a new user and use Mac to stream Z. every time `I launch the app on my Mac password field is empty and not supported with copy/paste and/or keychain/password management on my machine. please support

Hi @Mariusz_Jarzabek welcome to Zwift forums

This sounds more like an issue with Keychain. If Keychain isn’t turning on, you might try these steps on Apple’s support pages:


Thanks for prompt reply

I do not agree its Apple keychain issue. All other apps and web pages works without any prob. on my machine

I found a topic that this issue was solved (was an issue some time ago). Now with new macOS Big Sur seems not working again. From UX perspective its annoying and nowadays looks odd


Ok then. You might try clearing the app cache:

A more brute-force way to clear cache is to:

  1. search “Zwift” in Finder
  2. delete every folder and file that comes up in that search
  3. manually download and install Zwift again
  4. if prompted to allow permissions to the Documents folder - allow it.

Would you let us know if either of these measures worked?

hi there
I reinstall the entire piece and it works without any problems

1 Like