Pace Partner + Event causes crash [SOLVED]

Zwift went currupt whilst saving my ride

Anyone that experienced the same issue lately?

In companion app my ride is still active eventhough I’m lying on the couch…

What are your fixes?

Im running Win10, all updated

Cheers

Hi @Christoph_Weisl welcome to Zwift forums
Shuji at Zwift HQ here. I looked at the partial log files that’s saved to our servers to see if there’s evidence of network disruptions. If network disruptions happen as you’re saving & uploading your session data - it can cause the app to crash.

If network disruptions happen mid-ride, that can manifest as all other avatars disappearing and you’ve left by yourself in an empty world. Have you seen that symptom, by any chance?

You can locate your log files and upload them to zwiftalizer.com to see the network performance charted out, like these three of yours that I checked at random:



This might be easily improved by rebooting your modem, WiFI router, and laptop in that order to reset your local network. There are some more in-depth steps you can take to improve your local network performance. Would you try the easy steps and let us know if that clears things up?

1 Like

Curious - did you by chance get a survey to complete, or ride with the Pace Bots on that ride @Christoph_Weisl ??

1 Like

no race pot, no survey… My mate had the same issue some hours earlier… Maybe it’s a feature?

1 Like

I noticed that when I ride with a bot, and complete post ride survey, saving causes the app to crash. To be more specific, I warm up riding with a bot, then join an event. After the event I end the ride and get the survey prompt. I reply to the survey, then try to save. The app then crashes. See log abstract below.

{“app_name”:“Zwift”,“timestamp”:“2020-09-02 21:46:54.00 +1000”,“app_version”:“1.0.54684”,“slice_uuid”:“7cffac28-77ba-344a-be22-ff427ffd0df8”,“adam_id”:1134655040,“build_version”:“1”,“bundleID”:“com.zwift.ZwiftGame”,“share_with_app_devs”:0,“is_first_party”:0,“bug_type”:“109”,“os_version”:“iPhone OS 13.6.1 (17G80)”,“incident_id”:“E0BD86A0-CBD9-46A6-A55C-1B20FE141D9A”,“name”:“Zwift”}
Incident Identifier: E0BD86A0-CBD9-46A6-A55C-1B20FE141D9A
CrashReporter Key: b01e8c6becc43235194d3d242b4f9e4109fff93a
Hardware Model: iPad11,3
Process: Zwift [208]
Path: /private/var/containers/Bundle/Application/C391EE17-ADEB-408D-93EC-348D7F7D78FE/Zwift.app/Zwift
Identifier: com.zwift.ZwiftGame
Version: 1 (1.0.54684)
AppStoreTools: 11E707
AppVariant: 1:iPad11,3:13
Code Type: ARM-64 (Native)
Role: Foreground
Parent Process: launchd [1]
Coalition: com.zwift.ZwiftGame [330]

Date/Time: 2020-09-02 21:46:53.7785 +1000
Launch Time: 2020-09-02 19:47:32.8832 +1000
OS Version: iPhone OS 13.6.1 (17G80)
Release Type: User
Baseband Version: n/a
Report Version: 104

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Subtype: KERN_INVALID_ADDRESS at 0x0000000000000000
VM Region Info: 0 is not in any region. Bytes before following region: 4332732416
REGION TYPE START - END [ VSIZE] PRT/MAX SHRMOD REGION DETAIL
UNUSED SPACE AT START
—>
__TEXT 0000000102404000-0000000102ee8000 [ 10.9M] r-x/r-x SM=COW …ift.app/Zwift

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [208]
Triggered by Thread: 0

Thread 0 name: Dispatch queue: com.apple.main-thread
Thread 0 Crashed:
0 libsystem_platform.dylib 0x00000001b8882b24 0x1b887d000 + 23332
1 Zwift 0x0000000102faf67c 0x102404000 + 12236412
2 Zwift 0x0000000102fb5dac 0x102404000 + 12262828
3 Zwift 0x0000000102f89cd8 0x102404000 + 12082392
4 Zwift 0x0000000102d9b698 0x102404000 + 10057368
5 Zwift 0x0000000102d96744 0x102404000 + 10037060
6 Zwift 0x000000010308e2c8 0x102404000 + 13148872
7 Zwift 0x0000000102e0d198 0x102404000 + 10523032
8 UIKitCore 0x00000001bccd59e8 0x1bc239000 + 11127272
9 UIKitCore 0x00000001bccd5ae4 0x1bc239000 + 11127524
10 UIKitCore 0x00000001bcce3e90 0x1bc239000 + 11185808
11 UIKitCore 0x00000001bcce5670 0x1bc239000 + 11191920
12 UIKitCore 0x00000001bccc0840 0x1bc239000 + 11040832
13 UIKitCore 0x00000001bcd43da4 0x1bc239000 + 11578788
14 UIKitCore 0x00000001bcd46988 0x1bc239000 + 11590024
15 UIKitCore 0x00000001bcd3e8c8 0x1bc239000 + 11557064
16 CoreFoundation 0x00000001b8afad14 0x1b8a4e000 + 707860
17 CoreFoundation 0x00000001b8afac68 0x1b8a4e000 + 707688
18 CoreFoundation 0x00000001b8afa3c4 0x1b8a4e000 + 705476
19 CoreFoundation 0x00000001b8af51fc 0x1b8a4e000 + 684540
20 CoreFoundation 0x00000001b8af4bc8 0x1b8a4e000 + 682952
21 GraphicsServices 0x00000001c2ed65cc 0x1c2ed3000 + 13772
22 UIKitCore 0x00000001bcca7744 0x1bc239000 + 10938180
23 Zwift 0x0000000102eeadfc 0x102404000 + 11431420
24 libdyld.dylib 0x00000001b8971384 0x1b8970000 + 4996

Thread 0 crashed with ARM Thread State (64-bit):
x0: 0x0000000000000000 x1: 0x0000000000000000 x2: 0x0000000000000005 x3: 0x00000001b8867300
x4: 0x00000000000062dc x5: 0x00000000fe352f8d x6: 0x0000000000000065 x7: 0x0000000000000000
x8: 0x000000012d97bf20 x9: 0x00000000d9849eb2 x10: 0x0000000000000000 x11: 0x00000000000007fd
x12: 0x0000000000000001 x13: 0x000000009263189f x14: 0x0000000092832000 x15: 0x0000000000000064
x16: 0x00000001b8882b20 x17: 0x0000000012800000 x18: 0x0000000000000000 x19: 0x000000016d9f9470
x20: 0x0000000000000000 x21: 0x0000000103720000 x22: 0x0000000103720000 x23: 0x000000010370e000
x24: 0x000000010370e000 x25: 0x000000000000000d x26: 0x000000000000000c x27: 0x00000002803caa20
x28: 0x0000000131982810 fp: 0x000000016d9f9420 lr: 0x0000000102faf67c
sp: 0x000000016d9f93f0 pc: 0x00000001b8882b24 cpsr: 0x20000000
esr: 0x92000006 (Data Abort) byte read Translation fault

N

1 Like

I had exactly the same happen today. Rode with pacer bot, then joined a group ride. After the ride got the survey and the ride then didn’t save properly. I started another ride straight away and got a message telling me my ride hadn’t ended/saved properly and did I want to resume it. I resumed it then ended and saved the ride and it seems to have saved okay.

Pace bot was a bit crap anyway so don’t think I’ll bother again if riding with them causes crash/save issues.

I’m running Zwift on Apple tv.

2 Likes

Thanks Christoph. I thought your problem may have been related to what the two other posters have reported here. I havent seen any frequent/recent reports of your symptons but per Shooj, oddness like that can often be attributed to data loss between you and mothership.

@shooj - didnt mean to derail thread but could you note these two additional posters here with the survey problem that has been reported in the Pace Bots thread. Its not exclusive to a platform as myself/others have it on Win10 also. Cheers

1 Like

This has happen to me the last 2 days after group rides on Apple TV. Prior to the ride I have been warming up with the pace bots. The rides aren’t saving and it returns me to the home screen. When I log back in it asks if I want to continue ride. Lost all my status and maps of the group rides.

1 Like

There can be more than one issue at play here, but there’s good news for those with flaky WiFi issues in the home, or other network glitches upstream of your house.

We’ve been working on an in-game alert that’ll come up as you’re about to save and upload if you’re offline. That feature will be in this month’s game update, so we hope to reduce the instances where this is the root cause.

4 Likes

I think this is a bug.

If you look at my logs you can clearly see that its trying to access memory that has been deallocated. I can’t tell what action is causing this but it appears to be very unlikely that in my case this is related to a network issue as I’d be surprised if you would get a KERN exception for a connectivity issue - I’m not saying that it’s totally impossible but unlikely the exception would be thrown at that level?

N

That’s really useful and will help with a lot of the questions that float around here, in your inbox as well as other forums.

Quick update on this - I rode with a pace bot last night and completed the survey. I noted that previously I hadn’t added a comment in the survey, so this time I did and the app saved the ride without issue.

N

I have seen this very same crash pattern.

Ride with bot
Jump straight to event
Race event and finish
See a survey about the bot
While uploading event to Strava Zwift crashes
Restart Zwift, continue ride, upload to Strava

Both events were races, I lost my placing in the first one because it turned into a normal ride.

  1. zwift /activity/629564063683821136
  2. zwift /activity/631023627509214112

I’m using an iPad that has never has WiFi or upload issues for the last 5 months or so.

Also, I cannot upload my logs because I don’t have an email client setup on the iPad.

Gang - our QA team has reproduced the crash when you ride with a Pace Partner then ride in an event in the same session. Thanks for flagging this up!

[insoc-109]

3 Likes

I had the same issue with two different MacBooks, both running the latest MacOS.

I should add that, last Wednesday, I started riding with a pace partner, then I joined one event and completed it, and then I joined a second event, all without exiting Zwift.

The fit file from the first event was fine. The fit file from the second event, however, was corrupted.

Last Friday, I started with a pace partner and then joined an event. When I was done, the event fit file was corrupted.

It would seem to suggest that the corruption only happens to the last event after one starts with a pace partner.

I should note that in the 3-plus years I have been on Zwift, I have never had any corrupt fit files that I can remember. Then I had two in one week.

1 Like

Just adding on - this is still an issue. Running Apple TV. Joined pacer bot to warm up (which I really like doing, btw), and then jumped into a race. The ride did not save correctly, etc. This has happened a couple times for me now.

@Brandon_Peterson_DIR
Please verify this cleared up for you on your most recent session when you had updated to game version 1.0.55226?

At the time you wrote this, you were on the previous version that had this bug.

Hi @shooj - everything looked good this morning! I was able to ride with pacer bots, join an event, and then a race, and all files saved as expected. Thanks!

2 Likes