Old Home Screen & functionality work around

Hi All,

A temporary work around to use the old Home Screen and its functionality.

I am a Mac user, so I do not know if this works on Windows, I’m sure the windows users out there will be able to confirm it.

Mac OS X

  1. Open Zwift App, click “LET’S GO”

  2. On the Pairing Screen, click the language icon (bottom right) and change language to “Francais”

  3. Click “PASSER” or “OK”

  4. You will be presented with new Home Screen, click exit icon (top right) corner then click “J’AI FINI” and let Zwift app close.

  5. Open Zwift App, click “LET’S GO”

  6. Let your devices pair then click “OK”

  7. You are now presented with the old Home Screen.

  8. Click on the pairing section in the middle of the screen.

  9. Click the language icon (bottom right) that says “Francais” and select “English” and click “OK”

10) Use the old Home Screen (in English) as you have in the past (all features of the old Home Screen seem to work just fine for me).

  1. When you finish a ride, save it as normal and return to the Home Screen.

  2. BEFORE you “EXIT” the Zwift app, go back into the Pairing section (middle of the Home Screen) and change the language back to “Francais”

  3. EXIT Zwift

READY TO RIDE AGAIN

  1. Open Zwift App, click “LET’S GO”

  2. Let devices pair, click “OK”, DONT change language on this screen.

  3. Once in the old Home Screen, select the pairing section in the middle of the screen and change the language to English.

  4. Use the old Home Screen as normal.

Make sure that every time BEFORE exiting the Zwift app, you have changed the language in the pairing screen back to French then Exit Zwift App.

Once you have done this once or twice, its very easy to do/remember and takes a few seconds. I’m sure there is a shorter/quicker way (please let me know) to get the same result but this has worked for me each time.

Hopefully this helps those that want to use the old Home Screen and its functionality in the mean time.

Ride on!

Chris.

Tried it on Windows 10 & it works.

1 Like

tried it also on Win & didn’t worked for me.

It doesn’t work anymore.