Not joining zwift Tri event?

I signed up for the 1130 (UK time) zwift Tri session andzwift didn’t give me the option to join the event like it usually does. It ended up just doing the workout solo instead. Anyone else experience this?

How did you sign up for the event? Make sure not to sign up using the companion app while on the Zwift start screen, do it before you launch Zwift or while you are riding.

If you don’t see the join event 10 min before the start , then open the companion app and un jion and re join, the join event should then pop up

Ah, ok. That’s what I did. I’ll know for next time not to use the companion app whilst the game is open to sign up.

Cheers

1 Like

You can use it while the game is open but only while you are riding.

Best of luck.

Ride On.

I’ve had a similar problem. I joined the event in my companion app. Logged on to Zwift and saw that my event was starting in a couple minutes but it never took me to the event. What am I doing wrong? I never even saw the start line. Thanks for any help!

Hi @Ann_Cools_Playmakers.

Have you recently updated Zwift to the latest version?

I have. Both Zwift and the companion.

Did you see the join event in the lower left corner.
image

Yup saw it was starting. I just didn’t get the option to ‘move’ to it and it didn’t automatically drop me in when I started the app.

That sound strange, I would suggest logging a support ticket and attache the log file of the ride that did not work.

Also point them to this thread so they can get all the information.

Sounds good. Thanks for the help!

1 Like

Same thing happened to me; had signed up to Bologna TT already early in the week (I was really looking forward to this…) and was doing my warm up about 30min before. I never got the Join-prompt and missed the event. Really disappointed now.

Android App up to date, Companion on iOS also up to date. Why can’t you join event manually?

I think you need to join through the Zwift Companion App to get the JOIN prompt. This happened to me as well and after joining through the ZCA, it worked correctly.
Didn’t see the prior answer so sorry for the redundancy.