No riders on course


(Nick Pratt TV5) #1

I logged this issue with support and they sent me here:

 

2 different PCs, Windows 7 & 10. Same network.  Has been working like a dream for months.  Now as of about 9 days ago, we could still log on, see leader boards etc (all with names and active changes) but there were no riders.

Nothing on our network had changed between when we started using Zwift and a week last Saturday.  As of Wednesday this week riders are back - at least on the PC.

 

When I try and login from a different network on my Mac (which which Ive also used several times in the past at multiple locations to run Zwift) Im now facing the exact same issue - no riders on course, but active leader boards.

Once we finish riding we can upload rides to Strava etc. so we clearly have a working network.  Three machines, two different Zwift accounts, 2 different locations / networks.  Same problem.

Is there anything we can provide to help diagnose this issue further?


(Nick Pratt TV5) #2

 

 

 

 

According to the Zwift App there are currently 386 riders on.  This is after I sat there for 60s:

 

 


(Jon Mayfield) #3

I’ll pass this info to our network guys and see if they’ve got suggestions.


(Roberto Duarte) #4

Hi Nick,

    The player positions the Game Client uses depend on UDP communication with the Game Server. You need to check that you are able to send UDP packets out on port 3022 and that you can receive UDP packets in. The most common problem people have is their firewall or antivirus software blocking access to that protocol or port, but as you’ve tested different computers in the same network you might have been blocked at the router or even at your internet cable provider. So please:

  1. Check your router configuration. It might have a firewall enabled and you may need to open UDP 3022. You may want to contact our support guys to assist you as they dealt with reconfiguring many router modules already.

  2. If that’s not the case you might need to contact your cable provider support to make sure they are not the ones blocking the UDP traffic. Please make sure to mention UDP port 3022 if it gets to that.

Please let us know if it worked and feel free to contact us for help at anytime.

Best regards,

Roberto


(DB Smith (65+)) #5

Just want to add that I have the same issue on my Mac. I’ve logged 12 hours in Zwift and I have NEVER seen another rider.

Mac firewall is disabled and also disabled AdBlock and Ghostery.

My router is an Apple Extreme (tower). There are no settings I can see that suggest that any port is being blocked; not sure how to check that further (or change it, for that matter!).

My cable supplier is Time Warner and I can pretty much say in advance that trying to ask them for any help will be a fool’s errand!


(Roberto Duarte) #6

Hi Dana,

    I have an Airport Extreme myself and the default configurations for sure won’t block UDP traffic originated from your computer. So if you don’t have an antivirus software with its own firewall the problem would need to be with Time Warner either at their cable modem level or some other “security feature” they may be offering. I know it may be hard to ask you that but I do think you should contact their support.

Roberto


(DB Smith (65+)) #7

Calling Time Warner “support” is an exercise in frustration. If that’s what I have to do to make Zwift work fully/properly, I’ll just use up the free (Strava) time and drop it when they want me to subscribe.

Time Warner “support” is an oxymoron.

One question:

The AirPort is set to “bridge” mode. I tried changing to D…/NAT mode but got the error “double NAT” so switched back. Does the “bridge mode” setting have anything to do with it? (I know nothing about that kind of stuff).


(Nick Pratt TV5) #8

Just to be clear here: Everything used to work just fine on the 2 PCs and the Mac at multiple locations (different Optimum accounts).  This is a recent change and given that both internet links are business accounts I’d be surprised if Cablevision (in my case) changed this without notifying us first.

The 2 PCs have started working again - with nothing being done on our end - no router changes, no router config changes, no switch changes, no switch config changes - nothing on our network infrastructure changed. We do not auto-update anything with regards to network hardware.  All of our connections are wired.

 

Thanks for the info on the UDP links - I’ll check port connectivity here.


(Nick Pratt TV5) #9

@Dana Smith - the bridge mode refers to your WiFi access point extending the range of your incoming wired network.  Leave it at bridge - your cable modem is already likely providing you DHCP and DNS services.


(Roberto Duarte) #10

I don’t think that bridge mode is the issue. Looking at some ot their support answers on XBox support it does seem related to some cable-modem internal firewall: https://www.directly.com/p/time-warner-cable-can-you-open-my-firewall-settings-allowing-xbox-live-connection-for-me-66653. You may be able to look into it yourself if you have an admin user for the cable modem. Anyway I’ll ping our support guys, They’ve assisted many folks with network issues and they may already have a good recipe for you.


(DB Smith (65+)) #11

Nick,

As noted, I tried setting the AirPort to DHCP/NAT (instead of Bridge) and it didn’t make any difference to Zwift. But the AirPort was showing a error so I changed it back, anyway.

Roberto, 

I’ll fossick around a bit with the cable modem; anything you can get from your end would be appreciated.


(Nick Pratt TV5) #12

@Roberto Duarte:

Since the UDP connectivity is so important to the game, why doesn’t the game run a UDP port connectivity check and if that fails announce to the user the issue?  Just send a packet, wait for a response within 1s. If no response received inform the user and then keep trying every few seconds.


(DB Smith (65+)) #13

Roberto,

One clarification:

My ISP is Time Warner but I do not use their cable modem (I bought my own). From memory it’s a Motorola (actually the company who bought Motorola – can’t recall the name at present). The modem is about 2 years old and AFAIK current standard.


(Nick Pratt TV5) #14

 Mac build 1.0.9115 (just updated) fixes the issue. Everything works as it used to.  Nothing has changed here with regards to machine, network or configuration - just the Zwift update.


(Roberto Duarte) #15

Hey Nick,

    It’s odd because there were no changes on communication protocol so the same UDP 3022 is still required to exchange the player riding positions, but it’s great that things are working.

Roberto


(Roberto Duarte) #16

Dana,

    Can you try to look around your modem settings to check for firewall like configurations?

Roberto


(Roberto Duarte) #17

@Nick, that’s a very good point on the UDP communication test. We can surely make it clear when the UDP bi-directional communication was NOT

established and help troubleshooting it. We will include that in a - not so distant - future upgrade.

Thanks for the suggestion!


(DB Smith (65+)) #18

OK. Went to the Motorola cable modem setup. There is a tab for Firewall. IPv4 and IPv6 were both set to various levels of protection.

I shut off all firewall protection and, voila, Zwift shows riders, who’s near me, etc. In other words, that seems to have fixed it.

I will say as an aside that I’m not sure how comfortable I am being connected to the internet with NO firewalls, no adblockers, etc. I suppose I can turn them off/on when I’m not using Zwift. But there should be a better solution?


(Nick Pratt TV5) #19

@Dana - most modems allow you to selectively open a port.  Most also allow you to specify which port that traffic is opened to (i.e. the IP address of your Zwift machine - assuming you give it a static IP address).  have a look around for settings on “Port Forwarding” or “Virtual Servers”


(Roberto Duarte) #20

Hi Dana,

    You don’t need to open it all, you just need to be able to open UDP 3022 and your computer will be the one initiating the communication. Our game port requirements are in general pretty low: http (80), https (443) ports for standard http/https communication and UDP 3022 for high frequency / low latency player states. UDP is common requirement in most massive online multiplayer games because of the high frequency / low latency communication requirements this type of application has and that can only be accomplished through UDP.  In general firewalls try to block all unknown traffic and they usually allow http/https. In this case the UDP 3022 is now ‘known’, you know it is safe (if you trust us :-)) and you need to tell your firewall that somehow.

I hope to have helped more than confused you!

Roberto