No Ride On during rides

Same for me on the last couple of rides. Using Apple TV4K and iOS companion app. All apps up to date.

1 Like

I have opened a support ticket for this, and for the lack of group chat, since this topic appears to be somewhat neglected or ignored by Zwift.

2 Likes

You may not see Ride Ons during a ride if the person giving them isn’t giving it to you during the ride. A couple of examples:

  1. You spam/give out a Ride On to those in your near vicinity by pressing the little circle around your location on the companion app. You finish your ride. The other person(s) finish after you. They see you gave them a Ride On and to be courteous, they look you up and give your activity a Ride On as well.

  2. Your Zwift buddies/friends log in after you have finished your ride. Look you and your activities up and give you a Ride On.

In both of the above cases, you’d never see the Ride On while you were riding. The Ride Ons would appear after the fact. This is normal and to be expected. Give it a try, look up a buddy. Check out his activity list. You can give Ride Ons for any ride going back weeks as long as you didn’t already give him one.

As for Ride Ons in a group ride where those around you seem to be getting them. This also does not necessarily signify a problem. When in a group ride, to give Ride Ons to someone else in the group, it has to be one at a time. If you suddenly see 5 Ride Ons rain down, then someone from outside of the group sent them. Perhaps you weren’t the one of the closest five or whatever criteria Zwift uses to give out the Ride On.

If you’re not seeing any chat/messages, that would be a problem. Try sending a message yourself and seeing it appears on screen. If not, you definitely have a problem. I have only had this happen once.

Lastly, I too am using an Apple TV 4K and an iPhone.

The Ride Ons were given while I was riding. As soon as I finish the group ride, they are there to see in the Companion App. I can see everyone else’s RO appearing over their heads and in their pockets, but not the ones I receive during the ride.

I would be interested to know if others can see them arriving for me, I will have to try doing a group ride with a friend and get them to see what happens when they give me a RO.

The chat is of course the bigger problem, the RO are just a bit of fun.

I can see my own messages appearing, but not anyone else’s. This is a real problem during group rides, as you can imagine.

During a free ride, all of this works, by the way.

3 Likes

same here ATV4K, seen zero Ride On’s on yesterday’s hour long “free ride”, my attention was grabbed because of empty jersey pockets, which always have some stuff in it by the end of a long ride. I can’t remember about the chat tho because it was VO2max intervals day :slight_smile:

And today at the hour long group ride there was not a single message in chat except for those two I written (empty in both ATV4K and iOS Companion app) and same, no Ride Ons even tho I’ve seen how people around receive those.

1 Like

I’m not quite sure why you see a difference between group rides and free rides but suggest that you verify that your firewall(s) allow UDP traffic on port 3022 and TCP traffic on port 3023. If TCP port 3023 is blocked it will block e.g. chat messages.

No Ride On’s seen on Zwift or Zwift Companion? Still investigating

yesterday it started to work again, today everything was fine as well

Hmm that’s interesting, awesome! @Thorsten are you still having trouble with this via group rides?

I did a race (Innsbruck Team Challenge) yesterday, and everything worked as expected. I’ll try a group ride in the next couple of days, fingers crossed!

1 Like

I am having the exact same problem. No ride ons during ride but they show up in Companion afterwards. Also no messages on screen. I am on discord and asked others to give me a ride on and they did not show up. Empty pockets for me. I verified that there were plenty of messages going on too. I could see messages during my free ride but not any group rides. This has been going on for about 3 weeks. All worked well before. Apps are updated. Using Apple TV 4K too.

Thanks for the heads up Karen! Investigating. Has this happened constantly or just a one time thing?

It has happened on at least my last 3 group rides. I have restarted Apple TV several times and verified that app is updated. Also, on Companion the messages do not show up there either.
Thanks

Can you do a fresh launch of Zwift (close the app then restart it) to see if this error still happens on your group rides?

I have no group chat in group rides. Has been happening for several weeks now. Damn annoying…

I just did the new update and that seemed to fix the issue. I now have group chats and ride-ons.

I am having the exact same problem. No ride-ons during ride but they show up in Companion afterwards.
This bug came after update compagnion to 3.0

I might have found a way to fix it.
In option I had hide public discution cheked.
I just chek show public discution and the Ride On came back

I have been seeing a similar behavior since sometime in November. No ride on’s during a group ride and no group ride messages. This is on an iPad Pro 12” (Gen 1). I don’t bother checking the companion app; the main app should work :wink:

My firewall settings have not changed. I also close all apps on the iPad before launching Zwift each time. I had some BTLE issues in the past before making sure all apps were actually closed.

Thanks for the details Josh! Do you mind checking the companion app just to see if you receive those Ride On’s there? This helps us pinpoint possible sources of the issue.

Hey @Christian_Boudreau do you mind providing a screenshot of this “public discution” setting?