No resistance/ rollers lose connection after last update


(John Berry) #1

Launcher Version…1.0.19

Game Version…1.0.10979

On starting Zwift all devices Pair correctly (PowerTap G3, Elite Real e-motion Rollers, Heart Rate)

Rollers no longer appear to show active connection on device (Red light continues Flashing), no smart resistance is applied to rollers at all…

I had no issue on last usage 5 days ago on previous Game version (Sorry had to do some real world cycling)


(. TomH..) #2

Hi John, 

Sorry to hear but you can probably fix it in few seconds. :slight_smile:

  1. Exit Zwift
  2. Unplug the Ant+ dongle
  3. Wait 10 seconds 
  4. Plug it back in
  5. Launch Zwift 
  6. Repair your rollers
  7. Ride On!

This should fix. Give it a try and please, let us know if it worked. 

Thank you


(John Berry) #3

Hiya Tom

I raised a Support ticket as well…

Unfortunately unplugging the ANT+ Dongle didn’t fix, neither did un-install, clean the folders and re-install.

Device can be unpaired and repaired, Elite rollers show as paired and connected from within Zwift but do not show as connected on device (Red light blinking) and no dynamic resistance is applied

Rollers continue to work as expected in alternative applications, ie pair and rollers show as connected (red light steady), only in Zwift and only since last update do I have an issue :frowning:

 


(. TomH..) #4

Hi John, 

In fact I’ll be riding these rollers in an hour, let’s see if I experience the same problem and we’ll take it from there. I’ll get back to you soon. 


(. TomH..) #5

Ok John, I just tested it and it works fine for me with the latest version of Zwift (1.0.10979). So few things to check

  1. Can you confirm you have THIS model of rollers? 
  2. Can make sure your rollers are paired as Controllable Trainer
  3. Resistance is at least half way up in setting
  4. You’re hitting at least 5% gradient or higher

Thank you


(John Berry) #6

Tom

      1) Yes I confirm I am using Elite Real E-Motion B+ rollers using ANT+ connection

      2) Yes I confirm the rollers are paired as a controllable Trainer

      3) Yes I confirm resistance in settings is set to 50% (It was set to 80% prior to uninstall - reinstall and me clearing all directories - trying to resolve the issue)

      4) Yes I confirm in my testing I have hit gradients of 5%

 

I use a Power Tap G3 as power source/cadence source, could Zwift/Elite rollers being upset that it is not the Power Source i.e an active connection is not being established?

       I will try…

              a) Using a different ANT+ Dongle

              b) Un-pairing all devices and pairing only the Rollers as Controllable Trainer AND as Power Source, cadence.

If it then works I will re-introduce the Power Tap as Power source and see what happens…

Thanks for your help so far :wink:

 

 


(John Berry) #7

I have tried a different ANT+ dongle, unpaired all devices re-paired only the Elite Real E-Motion B+ rollers, as Smart Controllable Trainer, Power Source the Trainer, Speed Cadence the Trainer, it continues to not connect (Red light flashes) and no resistance control…

Trainer connects (Solid Red light) and works correctly using Elite Real software, TrainerRoad and Bkool, I therefore suspect it is an issue with the latest Zwift release (I had no issues before)…

Tom is your Elite Real E-Motion the B+ version? although that only really added Bluetooth, there may be other internal differences that may explain why yours works and mine clearly does not?

Shame I was enjoying Zwift, it just aint the same without resistance :frowning:


(. TomH..) #8

Hi Jonh, 

Thank you for all the information you provided. I’ve just tried using the rollers with Stages power meter and once again, it worked fine for me and yes I do have the B+ version. So because we’ve tried everything we possibly could I’ll create a ticket for you so our programers can take a look at this - you will have to provide the “log” file and possibly the “fit” file too.

One last thing to check - do you only use one Ant+ dongle at a time and do you only use Zwift program? (isn’t anything else running in background)? 

Also - Don’t worry, we’ll find out what is causing this issue so you can enjoy Zwift again at it’s best :) 

I also contacted Elite asking about software upgrade.


(John Berry) #9

Tom thxs…

Yes only one ANT+ dongle at a time, although I have three of them (dont ask) but only ever one plugged in at a time…

No other ANT+ utilising programs running, Garmin Express is disbaled from auto running (I find it annoying)…

I will install Zwift on a fresh built laptop tomorrow and try it again, to eliminate the machine and usb extension cable…

I am using a Windows 10 machine with a 5 foot USB extension cable ANT+ dongle is about 2 feet from the back wheel…


(. TomH..) #10

Ok John, 

Ticket has been created, we’ll follow in there. 

Once again thank you for your cooperation and I’m sure we will find the solution soon. :) 


(John Berry) #11

Tom

Don’t know how to reply / update ticket…

After deleting knowndevices.xml and prefs.xml and re-pairing (a few times), I noted that where power meter and heart rate where connecting, the smart trainer was connecting but frequently showing no signal or not re-appearing on app close/open…

I moved the USB extension cable from its convenient 2 ft away from trainer(dangling down the side of a bookcase) to a 2 inches away from the back wheel…

I have had my first ride with resistance since the Zwift update…

The ANT+ pairing does seem a little more temperamental and touchy than it was, but I do appear to have working resistance…

I did have the unit disconnect (Go from solid red to flashing red) during one of the Zwift sessions today, I have kept all log files if they are of any interest.

I changed the ANT+ Dongle to a Garmin one in the same position ie 2 inches from wheel) and the Trainer stayed connected…

Not sure why I would suddenly get connection issues post Game update? but positioning Dongle closer to trainer appears to have helped - interesting that only the trainer had issues and not the lower power (Power Tap hub and Heart Rate monitor)

Thxs for your help again…

 


(John Berry) #12

I give up…

No resistance control on Rollers again…

ANT+ pairing very flaky, mid ride Power Tap just got lost…no Signal :frowning:

It isn’t the ANT+ Dongle…I have 3, its not the USB cable, and its not the PC (Same issues on clean build laptop), rollers continue to connect and work properly in Elite Real, Bkool and Trainer Road.

Occasionally on shutting down Zwift the rollers connect…