No Resistance on TACX Vortex


(Rob Snyder) #1

Hi - I have the TACX Vortex Smart Trainer and having a very difficult time getting the resistance to work. I used this trainer with Zwift 4 months ago successfully and haven’t been back on for a while and now getting no resistance. I am connecting to the “Controller Smart Trainer” option and successfully able to pair to the device. I have searched these forums and tried a lot of different things, but nothing seems to be working. I did see where one post that indicated the trainer had to be at 3.1.7. (I am at 3.1.2 and it worked last time so not sure this is the problem), but also when using the TACX Utility App from my iPhone, it isnt giving me an option to upgrade past my current version.

Any help or suggestions would be much appreciated.


(Mark H.) #2

What is your controller source? PC or tablet?
Ant+ or Bluetooth conception?


(Rob Snyder) #3

PC based - using a Surface Pro with Windows 10


(Rob Snyder) #4

And ANT+


(Vincent Octeau WBR) #5

I have a genius smart with that problem as well yesterday. 

I unpaired/forgot the connections on my ios device. 

Paired it again with my ios device

used tack utility to update, calibrate and align

and

paired it with zwift.

Also, I made sure my internet connection was more reliable and consistent.

This said, of all those steps, I don’t know which one actually helped. But now it is up and running. 

Best of luck

 


(Rob Snyder) #6

Vincent - Thanks…what version of firmware are you running after the update?  Interestingly the Tacx Utility app is showing I am at 3.1.2 and it isnt showing any updates available so not sure how I get to a later version.


(Vincent Octeau WBR) #7

3.1.13


(Vincent Octeau WBR) #8

I am really no expert. 

I just turn on my app and trainer. 

Then checkmark/click on the device that shows up

then wait a minute before the update button is available 

 


(Vincent Octeau WBR) #9

The tacx utility app is 1.4.1 version. 

Maybe reinstall the app


(Mark H.) #10

You can only have one source controlling the trainer at a time.
With that said try turning the zwift off on your PC and disable the BT. as well.
Now you can start the Tax app. on your phone and update the trainer. (Make sure the BT. is ON)
Calibrate the unit after the update is completed.
Turn the app. Off.
Turn the phone BT. Off.
Restart the Zwift on your PC.
Confirm the functionality and only than start the mobile link app. on your phone.
Good luck.


(Jason K) #11

A couple other common reasons we see this happen:

  1. Make sure you’re pairing to the same Tacx Vortex entry in the pairing screen, not Tacx Pwr.

  2. Check your settings menu and make sure the resistance slider isn’t all the way to the left.


(Rob Snyder) #12

I am still really stuggling getting the resistance to work.  Thanks for all the answers, but any other thoughts.  I have tried two different PCs - checked resistance slider and it is in the middle.  Bluetooth on the iPhone turned off - using ANT+ on my PC.  Here are screen shots of me connecting…looks right doesnt it?  I first logged on via BlueTooth on my phone and checked for updates.  None available.  Calibrated on my phone - just spun up to 30Kmh - anything else I need to do there?  Turned off BlueTooth on phone and proceeded using ANT + on the PC.  No resistance and super frustrated!  Help :)  Thanks.

 

 


(Kevin West) #13

I’ll post here even though my problem seems slightly different. Same trainer.

I have a taxc vortex connecting to a Win 10 PC via the android mobile link app on my samsung galaxy note 4.

My problem is that the tacx vortex does not connect as a controllable trainer at all - only power and cadence.

Updated the firmware on my trainer and tried switched everything on and off alot.

I have managed to get it to work correctly via bluetooth straight to an ipad air 2.

I was going to buy an ANT+ usb dongle for PC to cut out the mobile link but after reading the above posts it seems that that might not fix the problem?


(Mitchell Bonner) #14

Kevin, see this link: https://support.zwift.com/hc/en-us/articles/213614686-Some-BLE-Smart-Trainers-can-t-pair-as-Power-and-Controllable-Trainer

I have the same issue with my new Vortex Smart with updated firmware.  The post is a few months old, I’m hoping they fix it soon.


(Kevin West) #15

I went ahead and bought a cheapo ant+ dongle and that works fine. Means I can us my garmin heartrate and cadence sensors too…


(Piotr JEFF Team PL PLCR) #16

I had the same problem with Vortex. Zwift can’t see them as controllable trainer. In may case the only way is to pair controlable trainer by ANT+dongle and at the same time Power source and cadence sensor by Bluetooth.

At first start I had all connections by BLE. Strange?!

 


(Yannick Bouliane) #17

For anyone having a problem connecting the Vortex as a controllable trainer via BT, try this:

  1. Start Zwift on your computer.
  2. Open the Zwift Mobile Link on your Phone.
  3. Plug in your Vortex and wait for it to connect to your phone. It should now appear on your computer as a controllable trainer.
    I’ve found it to work in my case!

(Anton Kovalnogov (B)) #18

Hi, I have the same issue when connect tacx vortex via BT and HR monitor via ANT+. Once I enabled ANT+ dongle the trainer immediately stopped produce resistance on hills (powermeter still works). 

So I forced to use ANT+ protocol for all devices, but then I get 3-5 seconds resistance lag on the hills which is annoying.

If the dongle is disconnected, trainer works perfectly, no time lags.