No resistance in climbs / Wahoo Kickr


(Trond Vidar Kjellen) #49

Setup: 2018 Kickr, 4iiii powermeter/cadence, Apple TV 4K, Ethernet.

So my last 2 races have been successful. I have deliberately connected 4iiii to the phone on these rides, and not the Apple TV. After seeing some of the comments regarding the cadence sensor possibly being the issue. The Apple TV can only support 2 connections, but an iPhone is rated at 10 connections - although 4-5 might be the practical limit.

Anyhow, I came to think that perhaps there is a bug that thinks the cadence sensor and the 4iiii powermeter is 2 connections, which means that they both fight with the Kickr over the maximum capacity of 2 Bluetooth connections that the Apple TV can serve. If the apple remote also uses BLE for commands, then this might be the issue for me.

Anyhow. On the last 2 races I have only allowed the Kickr to connect to the Apple TV bluetooth channel, and paired the powermeter, cadence sensor AND HR-monitor to the Zwift Companion app on the phone. I have not had any issues on those rides.


(Jonathan Assouline) #50

Hello,

@Vincent could you please provide clear answer on the above issue ?

Is a fix planned on Zwift side ? (if yes, anytime soon)
Your current procedure is quite heavy (we all like to step on the bike and launch zwift, not spending 30 mn before understanding which BT is taking over…)
Does removing the cadence sensor meanwhile and using only the kickR is enough until the fix ?

Thank you vm for your time,

JA


(Ruben Dankaart) #51

Strange thing, maybe helpful for Zwift/Wahoo. I had the same issues as everyone else here and did the following and have now been Zwifting with accurate resistance for a week. My setup is a Kickr 2017 with a pretty old Ipad:

  • Disconnected and deleted the Wahoo fitness app on my ipad.
  • Disabled bluetooth on my iphone and turned off any other bluetooth devices that were in that room.
  • Disconnected the cadence sensor and took out the battery.
  • Voila now it works.

Hope this works for others too!


(Craig DeMaio[DIRT] ) #52

Im going to give this a try thank you, Trond.


(Ronaldo Aguilar) #53

Hy guys. Anyone konws hot to fix my problem, the computer "see"and conect with the wahoo but the Zwift just keeps looking for it and it is not able to find and conect.
Thanks


(Vincent W.) #54

Hey Jonathan, great questions! Since these are related, Jon gave a statement on the resistance issues and a fix:


(David Greenyer) #55

Mine is a constant problem, no loss of connections. I have bought a KICKR and a Apple TV 4K and add devices via an android Tablet. I have never installed wahoo software. I dont see the ERG button anywhere, I have a constant resistance wether uphill or flat, the only difference is the virtual speed shown. Without gear changing this is isnt very engaging.
I’m still on 30 day trail, until this is solved I wont be paying any money monthly and will look to use traineroad or something. Hope you can fix or reply with a solution :frowning_face:


(Craig DeMaio[DIRT] ) #56

You will have to install the wahoo software to perform the spindown every two weeks. I will try to delete my wahoo fitness app before the next ride.


(HP Lund) #57

Setup:

*Kickr Core w/latest firmware
*AppleTv 4g
*CabLe (Garmin hrm and PowerTap pedals)

I experience no resistance issues especially during workouts with Erg mode (also during rides). Spun out at 150w @110rpm tonight. One thing I noticed, was that the resistance came back when I entered the menu trying to fix the issue. But it disappeared again when returning to the workout…

Don’t know if this has any value, but I’m sharing it as related input.

I’ll try to ride without the CabLe active tomorrow to see if it improves (cadence is part of the data feed from the PowerTap pedals).

I’m new to Zwift (member for one month), but sadly it has been to many issues so far.

Looking forward to the fix for AppleTv.


(Jeremy Diaz) #58

It was too frustrating waiting for the Zwift Devs to fix bluetooth. I’m not even sure that they feel like there is an issue. I decided to spend the extra money to purchase an Ant+ adapter, laptop, and laptop stand in order to get things to work as it should.

Ever since going to this setup, everything has been perfect. I haven’t tested using my phone in companion mode with this setup, but i suspect that will work too as long as I keep bluetooth turned off on my phone. I know only connect to my trainer via ant+ and it’s working great.

Hopefully the Zwift devs will get this resolved soon.


(Matthew Papapetrou) #59

Hey all,

So i had same issues as everyone using wahoo kickr 2018 connected tk ipad via BLE. Over last few weeks switched to my macbook and ant+ to solve the problem, which worked.

I updated the app today and used ipad again, connecting via BLE and all worked perfectly, so it looks like the update worked.

Guys thanks a lot for the support, other companies should take examples from your customer support.

Thanks


(Craig DeMaio[DIRT] ) #60

Is the update for Apple TV as well?


(Aaron Zwanzig) #61

@Jon indicated in the other kickr resistance thread that its for iOS and tvOS. Look for version 1.0.31648 or higher.

edit: Fixed the link to go directly to Jon’s post


(Pat Norton) #62

Setup:

  • Macbook Pro running Zwift
  • Zwift companion app (iOS - iPhone)
  • Wahoo Fitness app (iOS - iPhone)
  • Kickr 2016 trainer running the most current firmware
  • Kick HR monitor
  • Kick Cadence pod

I have had similar problems as others here with incorrect resistance on climbs and descents. I started having this problem sometime at the end of October, possibly associated with upgrading firmware on Wahoo Kickr. Fixed it today using some of the suggestions stated previously by others in this thread.

  1. Turned off Bluetooth on all phones/tablets/computers that had previously connected to Kickr
  2. Turn on Bluetooth with device that has Wahoo App
  3. Perform Advance spin down (see below).
  4. Turn off additional option on Kickr setting page (see below).
  5. Disconnect Wahoo app (kill app / turn off bluetooth on device)
  6. Turn on Bluetooth on device running swift
  7. Start swift and connect.

How to perform advance spindown and change KICKR settings:

  1. In Wahoo app, select “Sensors” --> select “KICKR”
  2. Scroll down and select “Spindown”
  3. Tap on the text above “Perform Spindown” repeatedly (5-6x) until “Perform Factory Spindown” appears
  4. Perform Factory Spindown
  5. Go back to the sensor page and make sure the below options are off (red arrows).

Unfortunately, I did both the factory spindown and turning off all of the setting options in the image above at the same time, so I don’ t know which one fixed my problem. If this works for you, you could individually reintroduce settings as needed and see if it interferes with the resistance working properly.

Additionally, I kept my Bluetooth off on my device running the Companion App (allowed it to connect via Wifi).

Good luck.


(Ray Garza) #63

WOW, that’s a flight to mars checkoff list to perform.

This is what I do on my Mac

  1. Before launching Zwift, reset the Bluetooth Module on the Mac (Shift + Option + bluetooth icon, Debug / Reset the Bluetooth Module
  2. Start Zwift and pair up normally
  3. Start riding

(Pat Norton) #64

Ray - I totally agree. Luckily, I only had to do this once. Now it just works every time I start Zwift.


(Ulrich Diederich) #65

Happy to report after doing the last Zwift iOS update my resistance issue seems to have been fixed. There is also a firmware update on the Wahoo Fitness app. It’s been three month.


(Per Johan Broden) #66

I am having issues with with the resistance, just started using Zwift a couple of days ago and realized that there is no change in resistance. Tried it in the Wahoo app and Erg works there. If I set it at 250 watts it changes the resistance depending on my cadence amd hits 250. Same when set to 100 watts. Now for the strange part. I “Forget sensor” in wahoo and connect to zwift. Now there is resistance. But it keeps aiming for whatever I set up in the Wahoo app, f ex 250 watts at my first try. Unpkugged the Kickr Snap and restarted it and Zwift. Then no resistance at all again. Repaired Kickr and Wahoo app and set it on 100 watts, it works. “Forget sensor”, again, and back to Zwift. It aims for 100 watts regardless of what the workout says. So it seems the set resistance in the Wahoo app somehow lingers until I unplugg the Kicker and after that there is no resistance. I am still on my trial period, but if there is no solution to this I will probably not sign up for Zwift and pay for ite just yet… I am using Samsung Galaxy S8 edge and Wahoo kickr snap. Help, please? :slight_smile:


(Aaron Zwanzig) #67

Perform the factory spindown in wahoo fitness. Then force stop both wahoo fitness and utilities. Then do a spin down in Zwift. See if that helps.

Eta: also make sure that you force stop any other app that might pair with the kickr, like rouvy or trainer road or the like.


(Per Johan Broden) #68

I will try that. Thanks. But the Spindown in Zwift has still not wotked for me, fails every time. Zwift stops at 2-5 kph and never reaches zero.