No "Power Ups" in Watopia Town

Since February Zwift Update no “Power Ups” at Start Banner in Watopia and London

Same here. Very annoying!

1 Like

Same for me :frowning:

1 Like

Ditto at start line in Innsbruck

1 Like

Also missing PU in Jungle today

I rode Watopia this morning, Hilly Route. No powerup through the downtown banner 1st time, got a powerup through both the KOM and Sprint banners, and got another one the 2nd time through the downtown banner.

I then reversed (with sufficient distance given) and did not get a powerup at the downtown banner again.

Maybe only when you go through the banner in that direction the first time?

Even so, it does appear to be a glitch…or an “feature enhancement” if you’re a software engineer.

:wink:

As I rode Watopia today going through the Downtown Arch I was using up my “Aero Power-up” expecting to receive another, but nothing happened. Usually I get a small window of rotating power-ups but no small window and no power-up.
Something has changed.

Yeah the last update fixed the power-ups going up AdZ, but seemed to turn them off at different spots around the island and other places. Please fix :frowning:

Seeing the same plus no Power ups on Alpe and Zwift did not give the Tour of Fire and Ice route badge. Also seeing power ups not working in other parts of Watopia i.e. jungle circuit counter

I’ve noticed during some races too, specifically in Innsbruck and Crit City. I got no power up, not even the XP bonus plus sign, and then other racers were popping aero helmets and draft busses. Seems to only happen on the first lap.
Check out my video for an example from TdZ stage 2 make up race last week:


at 1:09 someone uses an aero helmet

I rode the Big Foot Hills route in Watopia yesterday and even though you go through at least 6 banners, I’m pretty sure the only one that gave me anything was the KOM banner just outside of the Downtown area.

You go through the banners and it doesn’t even “spin” as it usually does, it just remains a blank white circle.

Something broke across the platform with the Richmond update, for sure.

:thinking:

Watopia tonight through the start finish banner 4 times no powers

Also got no PU at the Downtown banner.
Also none at the Volcano banner.

Volcano KOM, Watopia KOM, Sprint were fine.

NYC start banner borken as well. Oddly enough I did get the power-up roulette consistently as long as I did a u-turn after riding across the banner (no power-up), then riding across the banner again the other way (still no power-up), followed by yet another u-turn and crossing the banner a final third time (yes power-up).

No PU at

  • Watopia Downtown
  • Watopia Volcano
  • Watopia Volcano KOM
  • Watopia Epic KOM Forward
  • Watopia Zwift KOM Both
  • Watopia Jungle
1 Like

Even weirder: I rode a PRL Half with all power-up banners (*ox Hill, Tower, Mall) working normally, followed by a separate Greater London 8 with no power-ups at the same banners.

Let’s see if the 27th Feb Update fixed it :slight_smile:

Problem Today fixed, PU are OK!