No ERG, no calibration [German UI] [SOLVED]

I‘ve had my Zwift Hub for three days now (I’ve had an Elite Direto before that, level 37 on Zwift).
It works quite well, but (as others have also experienced):

  1. There is no calibration wrench icon and therefore no calibration. It did not show after updating the firmware when I set it up, it does not show now (much as I‘d like the coolsten calibration)
  2. In workout ode, there is no ERG button in the panel.
  3. According to DC Rainmaker, you can set it to „realistic“ for climbs, so that 6% feel like 6%. I canÄt find that option, either.
    Apart from that, the Hub is working well.

Andy suggestions? I wrote to support earlier, but thought this might be worth a try. Thank you!

To 2 and 3: it sounds like the trainer is paired as a power source only, not as controllable.

Hi @Jan_Tobiassen welcome to Zwift forums.

If you’re not seeing the calibration wrench, it may be because the Companion app needs to have Locations permissions in your phone’s OS settings. See this thread for the how-to.

Is that not setting the “Trainer Difficulty” to 100% in the main game Settings?

Not something Zwift Hub specific that one, it applies to every trainer out there.

The Trainer Difficulty setting only appears when a trainer is paired as Controllable

1 Like

All the suggestions giving here worked. It‘s fine now, ERG, cadence and realism all there. I was confused because of the German translation of „controllable“ and „steerable“, which is the same word in German.
Thank you for helping out.

1 Like

Glad to hear everything’s working as it should!

We appreciate you letting us know that the German translation could be better. I’ll pass your comments to our Localization team for review and improvement.