No community on Apple TV


(Michael Segalo) #1

When I ride with my iPad connected I see the community of riders. However when I use my Apple TV app, nothing. Just solo the whole time


(Tim Abbott) #2

First couple of times I used Zwift on new Apple TV 4k everyone was visible but over the last couple days no one to be seen!!! Is this a Zwift or Apple issue or is it  WiFi problem.Grateful for some feedback as 12.99 per month is looking even less good value at the moment! 


(Michael Segalo) #3

What’s weird is that I if I use the iPad or iPhone to throw it up using AirPlay it works. But I shouldn’t have to use that as a workaround and drain my battery


(Marc Camerlin) #4

I was having the same issues.  I was using a power strip (AC on/off) to turn off my monitor and fan after finishing Zwift.  However, the AppleTV was plugged into the outlet and left running.  It was programmed to go into power savings mode after an hour of non-use.  When I wanted to use Zwift, I would turn on the monitor and launch Zwift.  After the last update I started to get the same effect you are describing - no one else was visible.  I re-booted the AppleTV and voila - all was back to normal.  The next time I used the program I was back to no one being visible.  So, I set up the AppleTV on the power strip (so it gets shut off between uses) like the monitor and now all is well.  Every time I use Zwift I have to boot up the AppleTV and I can now see others. I don’t know why or what is happening to Zwift (I assume when the AppleTV goes into power savings mode) but re-boot times are very short so no real issue for me.   Hope this helps - I am really enjoying Zwift through the AppleTV4K.   Nice work! 


(Eric Lerch) #5

Last couple rides same thing on Apple TV. Solo is boring.


(Michael Segalo) #6

Unplug Apple TV and reboot. Works for me now after following direction Marc. Thanks BTW.


(Mike Sabadish) #7

Them I was having the same issue.
The solution is to power cycle your Apple TV via “restart”.
Riders will magically reappear after this.
The restart option is in the Apple TV settings menu and power cycling takes 15-20 seconds.
Needs to be done before each ride. Hopefully someone at AppleTV or Zwift is working on a fix, but this solution works for now.


(Eric Lerch) #8

The restart does work. Thanks all!


(Brian McKeown) #9

Same thing for me and restart is the only thing that works Come on Zwift get a fix for this please! Small first world problems I know but still …


(Eric C. (Zwift HQ)) #10

Hi everyone,

We are aware of the issue and are working on resolving it.


(Brian McKeown) #11

Thank you !


(Anego Montoya) #12

Hope the fix comes quick…real hassle to re-boot all the time.  I have the same problem.


(Nick Cooke) #13

I had the same issue - if you leave the app running for any length of time you’ve got the roads to yourself which, sometimes, is a bonus…

Rather than rebooting the box, when you’ve done riding & quit back to the main apple menu, double click the TV button on your remote, swipe right to the (still running) zwift app & swipe up to close it. Works for me & not too much of a PITA.


(Anego Montoya) #14

Thanks Nick…will try that.


(Eric Landes) #15

Wondering if anyone is having this issue: I am having a problem whereby the calibration function fails repeatedly and resistance is not being controlled. Worked fine for the first couple rides, but now I am spinning out in 53x11 at 60W. The app is otherwise working great. 

It also works fine on the phone, so I’m assuming it’s the signal to and from ATV. 

I will try the reboot to see if that helps. But I would be interested if I am alone in this or are other people having the same issue?

Oh, and using Cycleops Hammer and latest ATV


(Anego Montoya) #16

Eric, I have a had a few APV issues and have heard that was one.  I have  the Direto and haven’t had that issue, but word was APV has an update coming to resolve.  Best of luck


(Eric Landes) #17

Thanks Anego. My Apple TV seems to work with the reboot option others have tried above, but what I still notice is if I end a ride and start another in the same session, it stops working again. I’m not bothered too much at this point. Bugs take a while to work out. Happy riding!