No ANT+ DOngle after update to 1.0.6103


(Max Olei) #1

I have tried with 2 different ant+ usb pens.

Both worked like a charm before the update.

Both are listed in Device Manager,one as ANT USB-m and other one as ANT USB Stick 2 and work fine with other software.

Garmin connect is not launched so the pen is not used by other programs.

I have tried to change usb port but not luck… :frowning:

 


(Max Olei) #2

Inserted both ant+ dongles at same time and worked again…

If i insert only 1 ant+ dongle doesn’t work.

There is some log about this kind of problem ?


(Jon Mayfield) #3

If one dongle doesn’t work but two does, it means some program is grabbing your first dongle you insert, and then zwift finds the next available dongle.   It could be that garmin has recently updated their software to be more aggressive about grabbing the dongle, or it could be software from any other software package.  I’ll update our garmin software here and see if something changed on their end.

According to our logs your dongle was found only once after updating to 6103, but it was at least found that first time.  No ANT related code changed between 6098 and 6103 (in fact, almost nothing changed except an image).  It does mostly confirm what you say, but the timing with the version change is probably a coincidence. 

One final thing, we have seen (very rarely) that the ANT driver goes dead after many weeks of having a PC on without reboots.  Have you tried a reboot?

Jon


(Max Olei) #4

I have checked better with Task Manager and i have found Garmin Service active !

Maybe some update on Garmin Connect caused the problem.

If i kill garmin service Zwift works perfectly !

Thank yoy for the help !