My Apple TV has hung

Happened in the Four Horsemen race with PETA-Z. Really frustrating for ATV users. Let’s hope Zwift can fix this bug soon.

1 Like

Still happening at the Arch about to descend AdZ, and has been happening for me on ATV 4K since the summer at least.

Really not good - it’s not too terminal on an Alpe climb as I can freewheel down & close the ride on companion app, but no way I’d try a longer event / route while it’s like this :frowning:

The latest reply I got from Zwift this morning seems to suggest it might be like this for a while:

The fix for this issue was included in version 1.16.0 but we are receiving messages that the problem is still persisting. Our team is working on a new fix so I can’t provide you the exact date of update that will fix this.

1 Like

Thanks for posting this. At least they are working towards a fix (fingers crossed) :+1:

1 Like

Same thing happened to me 2 weeks in a row on the Alpe decent after crossing the finish line at the top using Apple TV 4k. No more Alpe for me until this is fixed!

I thought (foolishly) that maybe now that there have been a couple updates the problem would be fixed, but zwift crashed at the exact same spot on the alpe during Four Horsemen…

At this point I believe it is impossible to complete Four Horsemen on an AppleTV. That’s ludicrous. A random crash that happens under random circumstances would be hard to nail down and fix. A specific crash that happens at a particular location should be WAY easier. And this is game breaking, this should be top priority for the AppleTV team.

First time I’ve ever had a Zwift crash since I moved to ATV over 18 months ago. Yes you guessed it was at the top of ADZ which was part of “PACK SUB2 v the 21” group ride.
Luckily had the app running so descended watching this and saving to Strava after.

COME ON ZWIFT, LETS SEE A RESPONSE AND FIX PLEASE!

were you able to continue riding based on companion?

Sounds pretty similar to the ATV/iOS bug in bologna that crashes at the banner. Does not seem to happen for everyone though but it’s pretty annoying.

1 Like

Same issue when doing WEDU ride four horsemen yesterday. Third time for me with this annoying issue. Tried to move .fit file to Training Peaks but TP was not able to open it. Guess that there was error in that file also.

Same here after an Alpe race on December 12 - frozen screen on Apple TV upon crossing back under the banner to start the descent. Glad I hadn’t opted for the four horsemen ride instead.

It’s not like I lost a prize purse or even a victory, but a pain nonetheless.

i got same problem

Same problem right now. Is there a way to get the fit file?

not from the Apple TV

Just a quick update: I shut down the Apple TV Zwift app and restarted it and could resume the previous activity. I was at the bottom of the ADZ with all my ride data including the downhill all saved. I could even have continued riding.

So everything’s fine for me.

You should be able to log onto your zwift account on the zwift web site, find your activities, and hopefully your activity up until the crash will be there. If you go into it, there’s a little gear menu that should have an option to download the file.

Also when mine crashed I was able to start another ride, and zwift would ask if I wanted to continue my previous ride. By continuing, I was able to save my ride and then quit out of it before it crashed again. Other people have apparently been able to actually continue their rides…

Just adding my name to the list of people impacted with this bug. Froze durning race up Bologna two weeks ago part of Electric Spirit Series where happened to several people. Then froze today (December 16th) on the ADZ banner coming back down.

Surprised this has been going on so long. I’ve not had a full on ATV freeze like this before.

Seriously Zwift, this is so disappointing. Happened to me after 2,5 hours on the Four Forsemen. Nothing to be saved, I was seriously at 80% of the ride.

This bug is existing for months now. And nobody from Zwift is responding… How can @Eric talk about improving user experience in podcasts while a problem like this isn’t tackled or even recognized?

PS: I am really polite in this text. I am steaming from anger…

There may be more action happening here at the moment-

It is a very frustrating bug.

I am doing an alpe ride tomorrow as a group ride. I am going to see what happens if I just keep pedaling for a while when the graphics glitch out, if I can coax zwift into continuing my ride. Some people have said that companion continues to work even when the graphics are frozen…

I really wish I’d seen this thread before attempting the Four Horsemen. Exact same thing just happened to me now during a meetup on Apple TV :frowning:
I was given the option to resume the ride but every time I started pedalling it crashed again. Tried different things like exiting Zwift, and restarting the TV. Nothing worked and I admitted defeat. (3.5 hours lost for me).
Never had any issue at all before, and I’ve racked up many miles and nearly all the route badges.

Is this happening on all models of ATV? I don’t see many references to generation / model or year