My Apple TV has hung

Same issue here with ATV.
Seems to have started for me in early November.

Hasn’t this issue been brought up enough times now for it at least to be acknowledged by Zwift as an issue? Ideally fixed too, of course, but even acknowledgement would seem like progress.

@shooj ?

Darn it this one just hit me. End of Uber Pretzel. About to go down the hill. I guess my legs still get the fitness but it kinda sucks to not get the sweet sweet strava data.

Seriously though I was pretty upset. Just rode 6 hours and then get a crash, was like a slap in the face. I’m calm now but it did kinda suck!

I’m on AppleTV 4k, would need to double check the model. I am kicking myself for not dual recording.

So the data was actually there still! Sucks that I didn’t get to ride down the alpe with my friends but oh well. When I started zwift again and then went through the entire process of starting a ride, it allowed me to actually store the data. I feel much better now that I know there is at least a failsafe! Would be nice to not have the crash in the first place though.

Same here, AppleTV 4k, after banner Alpe de Zwift, 2 time of 2 last 2 weeks have screen been frozen, I managed to save ride after restarted ATV first time , but I was not able to save it yesterday😡 Zwift, this must be fixed asap.

Same happened to me today after completing Uber Pretzel… it froze when attempting to descend ADZ 5 times!! Each time I closed Zwift on my ATV and resumed activity and it froze every time before I gave up and just saved the activity…. Which only saved as “Watopia”.

Same problem here. The last two times I did Alpe du Zwift after the cinematic at the top Zwift hung. Very frustrating.

Same happend today during a groupride while doing the Uber Pretzel. When will this issue finally be fixed, @Zwift?!

And to me on the same ride as Marvin van der Salm above. ATV freezes completely when going back under the banner on top of the Alpe and although I could hard close the app and rejoin, as soon as I started pedalling it froze again. Great if a fix could be found, Zwift team.

They need to fix this issue, I was thinking it could been my ATV a couple generation old and I was willing to upgrade it but seems like it happens to newer models. ATV has been such a solid choice for long rides and it’s disappointing to see there seem to be more regressions with every new release. Yes they have to deal with many operating systems and versions, but that’s part of software development.

🤷🏻

I emailed Support about this on November 21st and finally got the following on November 30th after some back-and-forth:

I understand the inconveniece of route seletion, and I’m sorry for that. I was able to confirm that the next version (1.16.0) will include a fix for this issue, however there’s no certain date.

Unfortunately, that makes no sense since we’re on version 1.19.2 as of November 29th, 2021 on Apple TV. So I’m now waiting for clarification on the version that will actually have the fix.

Zwift support and “ambassadors” are noticeably absent in this thread.

I cancelled my subscription a year ago because of similar and common ongoing problems. Occasionally I ride on a club account (using my own gear) and still see similar random crashes and hangs.
What people are experiencing may or may not be related and there could be fifty different issues on this page.

I run ATV as a dedicated Zwift box. No other installed apps to potentially conflict. Sometimes I could resolve problems with a full reset on the ATV, update tvOS then reinstall Zwift.

Seems more often it doesn’t fix it now, but it is always worth a try.

Christine.

Today sadly for me the same issue on the alpe running zwift on Apple TV.
A great race of the herd but right after te banner zwift froze on me. Nothing todo then frantically trying all the buttons but nothing else todo them pull the plug.
Snif snif

My cousin and I both had the same issue when crossing the banner right before beginning the descent. This was during the WEDU Four Horseman Sunday Sufferfest ride.

Happened in the Four Horsemen race with PETA-Z. Really frustrating for ATV users. Let’s hope Zwift can fix this bug soon.

1 Like

Still happening at the Arch about to descend AdZ, and has been happening for me on ATV 4K since the summer at least.

Really not good - it’s not too terminal on an Alpe climb as I can freewheel down & close the ride on companion app, but no way I’d try a longer event / route while it’s like this :frowning:

The latest reply I got from Zwift this morning seems to suggest it might be like this for a while:

The fix for this issue was included in version 1.16.0 but we are receiving messages that the problem is still persisting. Our team is working on a new fix so I can’t provide you the exact date of update that will fix this.

1 Like

Thanks for posting this. At least they are working towards a fix (fingers crossed) :+1:

1 Like

Same thing happened to me 2 weeks in a row on the Alpe decent after crossing the finish line at the top using Apple TV 4k. No more Alpe for me until this is fixed!

I thought (foolishly) that maybe now that there have been a couple updates the problem would be fixed, but zwift crashed at the exact same spot on the alpe during Four Horsemen…

At this point I believe it is impossible to complete Four Horsemen on an AppleTV. That’s ludicrous. A random crash that happens under random circumstances would be hard to nail down and fix. A specific crash that happens at a particular location should be WAY easier. And this is game breaking, this should be top priority for the AppleTV team.