Milestone Pod No Signal


(Brian Keen) #1

I have a Milestone Pod (foot pod) that was working great with Zwift run.  But now I just get a “no Signal” when I try to connect and it is not registering that I am running.  The Pod does connect to its own app so it doesn’t seem like there is a connectivity issue to the phone (iphone 5).


(Steve Copeland) #2

I get this occasionally with mine. You need to get it into run mode before it starts transmitting and sometimes that can take a minute or so at around 6kmh. It’s weird why it does it. 

The other way to do it is wave your shoe in a running mode in the air. 


(Ozsvari Oliver) #3

Same problem here, any solution?

 


(Todd Bray TeamEN) #4

I tried to connect my Milestone Pod for a run yesterday and like the others continued to get a “NO SIGNAL” message. I finally gave up and just ran on the treadmill.

The funny thing is the Pod recorded my workout so I know it was charged and operating.

Any solution to this problem? Zwift obviously recognizes the pod but isn’t actively connecting. 

Thanks for the help!


(Steve Norman) #5

Same here.  Zwift failed to pick up my Milestone Pod (using my PC) - no other devices trying to connect to the Pod at the same time.  Connects fine to my Phone after the run has completed.  I gave up in the end.


(Paul Allen) #6

Steve,

You would need to use the Zwift Mobile Link to bridge the Bluetooth signal to the PC, you cannot connect devices direct to Zwift running on a PC using Bluetooth.


(Barry Deane) #7

Same issue here using an iPad. Started having issues after the Run launch that happened recently. Never had an issue before that. Zwift finds the pod at times, but when I go to calibrate it disconnects/no longer recognizes.


(Geoff Worsley) #8

I had the same problem last night and gave up.   Today, I restarted my ipad, installed the milestone app too.   It all worked.   Technology eh! 


(Vee Pollock - GS Metro) #9

Any response on this one? I was connecting my MilestonePod via my iPad fine - it wasn’t paired) and then the last few times it hasn’t connected (when paired or not). The MilestonePod connects to the MilestonePod app on the iPad. The Zwift app connects to the Mac. Now zwift’s not finding the pod.


(Paul Allen) #10

Vee,

Make sure you close the MilestonePod app BEFORE you open Zwift, Bluetooth only allows connections to one device or app at a time and the app could be holding the connection.


(Vee Pollock - GS Metro) #11

Thanks Paul. MilestonePod app hasn’t been opened when I’ve tried to connect. Also tried turning iPad completely off, then on again and only opening Zwift.


(Paul Allen) #12

Vee,

Is the MilestonePod connected to your iPad’s Bluetooth under Settings? If so, disconnected it from your iPad and then open Zwift. The connection to the Bluetooth on the iPad under Settings is more than likely causing it not to connect to Zwift. 

The MilestonePod should only connect to Zwift and not be connected to the iPad, iPhone or any other app or device before opening Zwift.


(Vee Pollock - GS Metro) #13

Hi Paul. Thanks again. I haven’t checked that so will give it a go.


(Ozsvari Oliver) #14

Remove the battery from the POD ant put back after 1min., try again…


(Ryan Watt) #15

I had the same issue these last few days with Zwift not picking up data from the pod. I removed the battery from the milestone pod for a few minutes then replaced it. Shutdown all the bluetooth connections on the phone and restarted the phone just incase. Not quite sure which one fixed the issue but its working again. Thanks for all the possible solutions folks. One more possibility is that if your using bluetooth HR monitor, try connecting the pod first to Zwift then the HR monitor.


(Christopher Hintz) #16

My pod worked fine before the Run thing officially launched.  Now Zwift sees it but doesn’t recognize any movement.   I’ve made sure norther devices or apps are connected.  Any ideas?


(Ryan Watt) #17

Christopher have you tried all the suggestions I made in my last post? Try taking the battery out of the pod for at least 1 minute and then replace it. It worked for me.


(Steve Norman) #18

@Paul Allen - thanks - that was the missing piece.  On the bike I always use ANT+, so no need to use mobile link.

Seems strange that there is a need to use ZML as a bridge for bluetooth to a PC which has a perfectly good bluetooth 4LE module  - but it works!  (I also needed to remove and replace the Milestone Pod battery and perform a full reset to get it going again).


(Steve Copeland) #19

As far as I am aware it’s only Mac’s that support direct BL communication with devices. When I run Zwift on my Mac it’s fine but on a latest windows machine I have to either use ZML or the Cable BT LE adapter which combines the BT and Ant devices. 


(Christopher Hintz) #20

Ryan,

I tried the battery trick.  It sees the unit, but it won’t notice I’m moving and it says it’s disconnected when I try to calibrate it.  These screenshots are from yesterday.  No different today.  Still stumped.  It used to work flawlessly.