Makuri Islands crashing after Neokyo update [Windows 8]

My problem is solved since a week. A deinstallation with a new installation didn’t help, so I copied the complete Zwift folder from laptop Nr. 2 to laptop Nr. 1. Since that everything works fine again. There were no more problems to reach Makuri.

Helps you out, good for you… but unfortunately doesn’t fix the problem (for others).
I mean, i have multiple PCs/Laptops and smartphones available to run the application as well… but i want it to run on a specific one and cannot accept a crash without spec-related issue and no further information. Zwiftalizer shows nothing serious… :man_shrugging:

Great to already have the next application update with very minor fixes but nothing related to current issues of a lot of people. And as i heard now there are other Problems (like dropouts) on top.

Wanted to go for the “Uber Pretzel hunt” tomorrow… already afraid of the update :face_with_head_bandage:

RIDE ON everybody :call_me_hand:

I found the following:

  • the problem is not related to Makuri, I was able to simulate it in different worlds as well (under specific conditions).
  • in my case “ZwiftWindowsCrashHandle.exe” crashed every time as well, so if you Zwift devs rely on some info from this, it doesn’t show up in your dashboards.
  • the message from Windows itself is related to “Out of memory”. Note however, it’s not dependent on your actual physical RAM size. I removed one of my memory module (8G->4G), the situation was exactly the same, all worlds working but the Makuri. Zwift normally use 2.5G RAM in my case.

Finally, after some digging, I enabled Windows page file (which I disabled ages ago). For my 8G, I set it to 12G. User your favorite search engine with “windows 7 memory limit pagefile”, for instruction, how to set the pagefile (can’t include links, sorry).

Now the Makuri Islands map is working.

In my view, the problem is, that Windows doesn’t allow to overcommit memory. Zwift, as multiplatform app, may rely on that.

Hope it helps somebody.

1 Like

Windows 7 support will end within the next month anyway I’m afraid.

Please, stay on topic here, thank you. The problem described by the orignal author affects Windows 10, Windows 8 as well. See other threads.

Windows 8 support will end next month also.

The title of the thread is: Makuri Islands crashing after Neokyo update [Windows 8]

1 Like

Fair enough. My point was only that digging around in the system settings like this shouldn’t be necessary (and in my experience, isn’t), and whilst the changes working for you is good news, it’s tempered by the fact that it shortly won’t be relevant anyway.

It seems that the same method helps for Windows 10:
forums. zwift. com/t/crash-while-loading-makuri-island-win-10/565161/15

(Sorry, can’t post links, remove spaces after dots)

Again, fair enough. :+1:

It’s an interesting find, but suggests in both cases that the user had changed the default Windows settings in the first place. Putting them back appears to have ‘fixed’ the problem. Zwift can’t be expected to account for users messing with fundamental configuration settings, or be held accountable for it really. Glad you’re sorted anyway, it’s something to bear in mind and useful to share.

1 Like

I don’t blame anybody :-), just sharing my experience.

1 Like

Thanks Vladimir, good hint!!! setting the page file to some bigger (fixed) value really did the trick - will start exploring new routes soon :wink:
Have a good start into 2022 !!!

I tried the page file and tried to set it but still didn’t work for me. The game still crashed I set my settings back and it still crashed.

For me I was just getting the zwift app closing any time I Tried a Makrui island route, no BSOD.
Just went back to desktop.

The way I got it working on my PC (7+year old PC running a GTX1070 GPU8GB + 24GB RAM) was as follows -

  • UPDATE to latest Nvidia and windows drivers (Windows 10)

-Uninstall zwift and go to C:/ programs(x86) and ensure after uninstall you delete the zwift folder.

  • restart pc and go on the zwift site to download the zwift app and install the game.

For me, this got the Makuri island map working and tested multiple routes including the ones in the arcade no crashing!.

hope this works for you.

1 Like

I have an old computer with only 2 Gb memory, running Win 10.
Increased the page file settings to: minimum 5500 MB and max 8000 MB.

To my surprise it’s working now.
When you make the page file too small, it still crashes.