Makuri Islands crashing after Neokyo update [Windows 8]

No overclocks here, its more than capable without.Will try again today, found a Nvida game driver i want to try. But honestly, everything has been smooth for a long period of time, both with win 10 and 11, so it would be a BIG surprise if it’s the computer when the problem came with the update of the game. And i am obviousely not alone. First the companion app, now this.

Need to know your specs, really.

1 Like

No you don’t . But i will send the details to support , so they can provide them further to the genious software team. This is not about the computer, and the problems with the companion app on IOS is not about apple either. It’s about Zwift. Easy math , all the problems started with rhose new releases.


It’s always very telling when people with super amazing gaming PCs that can’t possibly be at fault won’t even offer up any information about it. Good luck with your problems.


Thank you

And good luck with Zwift support :rofl:
Dave could be more help, for sure.
If you are on FB, look at ZPCMR.


I am having the same issue but running Windows 10 v21
Only Makuri crashes, all other worlds OK
It crashes after selecting world (MI), any route, then after clicking on the Ride button, blue splash screen says Loading Makuri Island then application closes after 1 or 2 seconds.
NVIDIA GeForce GTX 1050 driver is up to date
Help Please!


No need, i do my stuff myself. But with the ongoing problem with the companion app on ipad and the problem with the Makuri world now i do it easy and cancell. A lot of apps out there, i am not dependent of Zwift. Use Xert as my training platform, so what’s rolling on the tv in the background is not important at all.

But you fanboy , why do you stay with a provider that you obviousely not trust will give you support ?

Started 4th winter @ Zwift yesterday, have an 8 years old PC, updated to Win 10 (years ago, before Zwift) and upgraded GPU for Zwift, 2 years ago. Had 1 (yes, one) issue during all the time - activity not saved - and have short dropouts in large events. Did not know why, that’s why I tried support and looked in the forums. Now I know why - thanks Dave.
And there are many people here who can help to solve your (I bet hardware) issue. You refused, your decision.

Fanboy? I enjoy the Zwift community, here in forum and on the virtual roads.

Ride on!


You bet, yes i bet you do. Strange that all with Ipad got a hardware issue when the companion app was upgraded. Strange that i got a hardware issue with only Makuri Island and was able to do 45 Km i Watopia after that.
But ok, i am sorry for the «fanboy» , not my intention to be rude. I’ve been on Zwift since 2017, level 50, tronbike bla bla. But not so important for me, i have a lot of other options that work.

Wish you all the best and good training.


100% agree. As only the new World is crashing, it has nothing to do with System specs… just updated everything… no improvement, just a very rude application crash.

1 Like

I have same problem after last update friday.

Only Makuri Islands.
Choosing route: blue screen loading Makuri Islands, then it’s over.
Or can ride a few kilometers and then suddenly exit.

I’m using MacBook Pro with Intel i7 M620 @ 2.67 GHz processor, 8 GB RAM, running in Windows 10 Pro, NVIDIA GeForce GT 330M
Everthing is up-to-date.
Using ANT-dongle for HR and Tacx Neo T2.
Screen full HD, settings in Zwift tried 576p and 720p.
Already completely deleted Zeift programs and C:\documents\zwift and reinstall

Just ride on Watopia, no problems

Also send log-files by email to support.

Donald Groen


If it’s nothing to do with your specs, how do you explain the fact that it’s absolutely fine on many other systems, and more importantly how exactly do you expect them to debug and fix it without knowing what you’re using? Absurd attitude.


If this have something to do with the specs than they shift the requirement for the specs without inform. That’s the only posibility . And your opinion about our attitude is absolute uninteressting.

1 Like

I’m having the same issue on Makuri Island too. Sometimes crashes after blue screen and other times a few kilometers in.

Running Intel i5, Windows 10 Pro (21H2). All drivers updated. Uninstalled and re-installed Zwift but no change.



Actually, Dave is expressing his opinion about YOUR attitude. Part of why he’s asking is to help you and part of it is to get more data about hardware subject to this failure. Personally, I find your attitude … “Interesting”. :rofl:


I received answer from Zwift support.

According their info my graphic card in my MacBookPro (medio 2010) (NVIDIA GeForce GT 330M does not meet the minimum requirements (Intel HD 4000 or AMD R5 graphic card).

Should try other device…

I will test later today my Dell XPS, it has a Geforce GT 550M on board. Will see if this works.

Otherwise it must be new pc/laptop for using Zwift :frowning:

Donald Groen

I have the same issue as other posters (crashes on loading directly into Neokyo, Win10, latest drivers, all other maps fine). I was ready to blame my aging GTX275 not being able to do some DX11 stuff, or similar - but then I managed to load Makuri Islands Farmlands, and ride into Neokyo and do multiple circuits without crashing.

However, I still get immediate crash to desktop on trying to load a Neokyo route directly. Very frustrating. Open to any ideas (short of buying a new GFX card…)

This is an interesting workaround, wonder if anyone else can have similar results?