macOS client bugs

Activity id: 937539464836710400
MacOS Big Sur 11.6
ZwiftApp (and Mac) has been fully restarted since last Zwift auto-update.
On startup, the UI briefly shows version is 1.18.1 (85684) on the Logging In dialog.

1. About ZwiftApp not working: harder to find version number
Menu/ZwiftApp/About ZwiftApp - pops a dialog showing a folder icon and the single word ZwiftApp. Clicking the icon does nothing.

2. U-turn not functioning
I chose to join a friend on Zwift by clicking on their name in the menu screen, and joined them in Watopia. I rode with them for a while, but lost them after some time. Later on saw a Pace Partner, and tried to use the down arrow key to perform a U-turn; it slowed (braked?) me, but did not u-turn. I then used my mouse to click on the bar chart area to reveal the UI buttons, and clicked on the 2nd icon, u-turn; again, this did nothing. Tried both during a turn and on a straight, both pedalling, and freewheeling, at various speeds.

Possible relevant logs:
[10:02:02] NETCLIENT:[INFO] Auxiliary Controller attempting to connect to phone at:
[10:02:02] NETWORK:error (6) sending player state
[10:02:02] NETCLIENT:[INFO] Auxiliary Controller failed to connect to socket: ‘Host is down’ (64)

I was only running the MacOS client, and today I was not running the Companion on my phone. Is it required to run both to perform u-turns?

3. untranslated string
I got a free month added to my subscription when I purchased an Elite smart trainer. On the initial window (with buttons “Change User” and “Let’s Go”) - I see the string “zwift.edition.elite.1.month (Active)” to the left of WELCOME (despite the fact I’ve paid monthly subscriptions both before and since this event)

See the various sticky threads in the Known Issues forum.

1 Like