Mac BlueTooth Issue

(Vicki Muse) #1

As of this morning, Zwift recognizes my phone but none of my devices.  I have worked with Apple to see if there is a hardware computer or phone issue and it appears it is in the Zwift software.  Does anyone know how to resolve?

0 Likes

(Eric ) #2

Hi Vicki,

How are you trying to pair your devices? Via ZML (as a bridge) or directly to the Mac?

0 Likes

(Vicki Muse) #3

Directly to the Mac.  I use Zwift Mobile Link.

0 Likes

(Eric ) #4

Can your devices pair directly to the Mac at all? And are they paired directly to the Mac (they shouldn’t be but I want to test if the devices are transmitting)?

0 Likes

(Marcos Rod) #5

If it helps…I have a Wahoo BlueSC and I can only pair the speed sensor/signal with my MacBook s Bluetooth. the cadence signal needs to be paired to with ZML. So I end up using ZML instead of the native Bluetooth on my MacBook.

0 Likes

(Marcos Rod) #6

If it helps…I have a Wahoo BlueSC and I can only pair the speed sensor/signal with my MacBook s Bluetooth. the cadence signal needs to be paired to with ZML. So I end up using ZML instead of the native Bluetooth on my MacBook.

0 Likes

(Vicki Muse) #7

Hi Marcos & Eric,

Thank you for all your help!   I have been using ZML.  It just suddenly stopped working.  The Application could see my iphone but never pick up the sensors.  I tried multiple times on two different computers.  The ZML link starting working again after I ran a Firmware update on my KICKR and removed and reinstalled ZWIFT application on my computer.  I was able to ride this morning!

Eric - I think there is a Mac bluetooth software problem.  Some devices will pair directly, like my keyboard and speakers but no the iphone or my trackpad to either Mac I tested.  I am hoping they will have a release soon to resolve the problem.  ZML is working now so it is no longer a problem.

Vicki

0 Likes

(Chris Sgaraglino) #8

Zwift just updated on my MacBook pro and now all the devices are gone and Zwift can no longer pair - none of them show up in list?

Not my Wahoo HR or Cadence or my Garmin Speed.

 

FYI: All connect fine with my Edge 1000

 

1 Like

(Eric ) #9

Well, the Edge 1000 uses ANT+, so it’s a different protocol.

Try disabling Bluetooth on your Mac, rebooting, re-enabling it and then starting Zwift up again.

0 Likes

(Chris Sgaraglino) #10

I have tried that - no go.

I have turned off BT and inserted my ANT+ USB Stick and it’s still not working.

And before you start pointing the finger at my Mac, so that I can ride tonight, I fired up TrainerRoad and I am not having any issues with BT or ANT.

 

0 Likes

(Gregg Bone) #11

I am having this problem also.  The sensors all connect fine with everything else (Strava, Ride With GPS, Wahoo Sensor tester - on my iPhone - so the sensors and KICKR are working), and my Mac connects fine to the keyboard, mouse, trackpad, headphones, and my iPhone, so the Mac is working…  but Mac to sensors through ZWIFT not.  I am still riding using ZML but often I have to force crash ZML and re-launch to get it to work in Bridge mode.

0 Likes

(Paul) #12

Gregg,

Make sure you are only trying to connect the trainer to the Zwift App since Bluetooth can only connect to one device or app at a time. 

0 Likes

(Gregg Bone) #13

I left out a VERY important clue:  The ZWIFT app on the Mac asserts in the top left corner that “It looks like your Bluetooth receiver is turned off” (just logged on and copied the error message)

Bluetooth is clearly on, I’m typing and using my mouse and trackpad.

0 Likes

(Jerry Vargas 60+NWCC) #14

Same situation here, for Sierra and High Sierra, multiple computers.  It is due to the latest software update “pushed” that cannot be stopped so it installs automatically. We need Zwift to FIX it!

1 Like

(Geoff Merris) #15

Everything worked perfectly until the Zwift update.  Now the Zwift software cannot find my Kickr, HR monitor or cadence sensor.  Zwift is now worthless on my MacBook 12".

0 Likes

(Gregg Bone) #16

This issue has existed for a very long time, 1st post about it in January.  I think Zwift is not even trying to fix this as this only troubles Mac users (a small group) and there is a workaround.  The problem is with connecting directly to the Mac Bluetooth in 10.10 and later as far as I can tell.  If you use Zwift Mobile Link as a bridge (select this in the upper right corner of the startup screen) and have ZML running on an iPhone or iPad (have not tried it on an iPod but I expect it would work at that uses IOS rather than MacOSX), after connecting Zwift running on the Mac to the ZML app the ZML app will connect to all the sensors and KICKR and everything will work properly.  There is another issue that complicates this issue a little, and that is that other apps that run on IOS do not let go of Bluetooth devices as they should.  An example of this is Strava, if you collect your real life cycling data with the Strava App, and it connects to the same Heart Rate Strap as you use on Zwift, the Strava App will need to be quit (double click Home button, scroll sideways to the Strava App, flick the App screen up to quit) to get it to release the Bluetooth sensor.  True with all sensors, cadence, speed…

 

If I select Direct Connect rather than ZML Bridge mode to connect to sensors I get an error message that says my Bluetooth receiver is turned off on my Mac.  If that were true I could not be typing this message from my Bluetooth Keyboard, and could not click on the SUBMIT button with my Bluetooth Mouse or Trackpad

0 Likes

(Henrik Ahrendt (SC)) #17

My Macbook worked fine with pairing my bluetooth devices in Zwift until I updated to Sierra High (I also read Sierra had problems).

I found a video where the guy suggest to delete the file:

Macintosh HD/Library/Prefererence/com.apple.Bluetooth.plist

When Rebooting Zwift again can find my trainer and HR monitor!!!

Here is the video tutorial:

https://www.youtube.com/watch?v=owQDfc7mf0U

 

0 Likes

(Tree Top Flyer) #18

I have the same problems running Zwift on a MacBook Pro (early 2015) with High Sierra 10.13.  It has recognized my Wahoo RPM Cadence Sensor and my RPM Speed Sensor in the past via Built In Bluetooth but took a long time to connect. It will not find them at all now and no longer will find my  Scosche HR monitor.

I looked for the Bluetooth plist file and it is not in my Library -> Preferences folder nor does it come up in any Finder search containing “bluetooth”

I have tried to turn off ALL bluetooth devices except my MacBook Pro and still cannot get my sensors to pair with it.  They pair without any issue to my iPhone Wahoo app. They do not pair easily to my ZML app.

0 Likes

(Tree Top Flyer) #19

Today I solved the problem on my MacBook. Press Shift+Option (Alt) and select the bluetooth icon at the top of the screen. Select Debug then “Remove all Bluetooth Device” reselect the icon and Debug and
“Reset the Bluetooth Module”

When I opened Zwift again all my Wahoo devices and my HR monitor instantly connected.

 

 

0 Likes