Mac blank screen, colored screen and black blocks [October 2021] [1.18.0] [SOLVED]

same problem here (Zwift crashing after clicking on “Let’s go”):

Hi all - thanks for your patience through this. The root cause has been identified and the team is working on a fix. We’ll provide more updates as we get closer.

8 Likes

@P_a_u_l - You guys should really develop a user story to give users the option to do two things:

  1. Revert to last installed version when updates like this happen bricking many users. Normally this shouldn’t be needed but this isn’t the first time your unit tests have failed you UAT.

  2. Allow users to upgrade when “THEY CHOOSE TO” and not automatically like it is now. Not sure why you guys force these updates but most companies don’t force the user’s hand.

Also one note on older laptops. Most Zwift users I know don’t tend to use their primary laptop or computer for Zwift. Some have to but many, like me, opt to use an older laptop and just dedicate it to the pain cave. As such, you guys have more of a need from you users to support older Operating Systems. For example, I can no longer update my MacOS past High Sierra on my 2011 Macbook Pro but it works great. I get that there is a limit to far back you can go but when it comes to macs the hardware lasts way longer than most PC’s.

10 Likes

Absolutely! Bugs happen, and I think most people accept this if they are addressed in a reasonable time. But the enforced updates with associated bugs cause people to miss team events. Even something like “A new update is available. You must update in the next X days” would give people the choice to not touch anything just before a race or for a chunk of the user base to leave it a few days before updating when early adopters discover a bug.

4 Likes

Same here…I recognize I have a dinosaur Macbook pro 2011, running High Sierra. But still it worked perfectly up to this update. Closes after clicking Let’s go, I tried rebooting/ upgrading system/installing app again.

The newly updated Zwift can not run on my old MacBook Pro on macOS High Siera, is this the case or else?

Please help

7 Likes

This is a known issue that zwift is investigating: Mac blank screen, colored screen and black blocks. READ THIS [October 2021] [1.18.0] - #32 by Sarah_Bergstrom_RAND

Mac Zwift update issue…where do I post? Updated today for Mac Pro retina 2015 model running Sierra…now riders and some areas of the screen background (hills, buildings, road - near view) all are black and heavily pixelated. Rest of it seems to work ok. Just big black blocks everywhere. Any help appreciated.


1 Like

Updated the app on my MacBook pro today and then experienced some funky in-game colours. Restarted … no change. Even reinstalled … still no change. Everything has been working flawlessly with heavy usage for last 18 months. Anyone else having this issue?




1 Like

See here: Mac blank screen, colored screen and black blocks. READ THIS [October 2021] [1.18.0]

1 Like

Cannot ride since the update on MacBook Pro. The game doesn’t render except the data overlays. Black screen once attempting to go into any map. Just brutal.

I’ve cleared the entire game and re-downloaded from scratch, no luck.

odel Name: MacBook Pro
Model Identifier: MacBookPro9,2
Processor Name: Dual-Core Intel Core i7
Processor Speed: 2.9 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 4 MB
Hyper-Threading Technology: Enabled
Memory: 8 GB
Boot ROM Version: 422.0.0.0.0
SMC Version (system): 2.2f41
Serial Number (system):
Hardware UUID: AD054B33-F343-5656-9DDB-342197460B47
Sudden Motion Sensor:
State: Enabled

1 Like

Sort of similar issue with latest update - see me comment below in this thread. Weird.

Similar problem for me - see me comment in this thread include screenshots

Same deal - At least you got in the game. I’m more the black image. You’d think they’d QA this a bit more before rollout…

I’ve emailed Zwift Support for details. Let’s see what they come back with. At least I’m confident that it’s an app issue … was 99.99% confident it was but thought there was a remote chance than my the video card in my old MacBook pro had finally kicked the bucket.

App will not launch this am. Drops after logon screen. Bug in new version? Using Mac osx

2 Likes

Same behaviour on my wife’s MacBook (OS X 10.11.6 El Capitan).

2 Likes
4 Likes

Hey @Charlie_R_Japadermaw, I overcame this issue in a rather analog fashion…

•1] ensure Zwift is only non- critical app running in activity manager.

•2] hook up HDMI to primary display and mirror.

•3] establish mirror, turn down mac display to dark, no light, and close MacBook. Have access to a wireless trackpad and… keyboard if you wish.

•4] place Ice-pads in ziplocks wrapped in cloth above And below closed MacBook to radiate heat.

•5] set in game frame rate at less than 30/sec and display at less than 720p.

•6] enjoy your Nintendo 64 Zwift edition.

Diagnostics showed it to be an overheating issue, this squashed it for the time being. Good luck!

3 Likes

Me too…:disappointed::disappointed::disappointed: